Read the docs

A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier…

Priority HIGH 78Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 fixed, 5 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier in pipeline-model-definition/src/main/groovy/org/jenkinsci/plugins/pipeline/modeldefinition/parser/Converter.groovy that allows attackers with Overall/Read permission to provide a pipeline script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.

Why it matters now

EPSS 0.81098 99th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD and the CNA
Fix Partial org.jenkinsci.plugins:pipeline-model-definition (Maven): 1.3.4.1Red Hat: 1 fixed, 5 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsPipeline: Declarative Pluginup to 1.3.3—No fix listedCNA
—org.jenkinsci.plugins:pipeline-model-definition (Maven)before 1.3.4.11.3.4.1Patch availableGHSA-x6jx-cxg3-mggh
  • Pipeline: Declarative Plugin VendorJenkins Affected up to 1.3.3 Fixed in — No fix listed CNA
  • org.jenkinsci.plugins:pipeline-model-definition (Maven) Vendor— Affected before 1.3.4.1 Fixed in 1.3.4.1 Patch available GHSA-x6jx-cxg3-mggh

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:pipeline\:_declarative:*:*:*:*:*:jenkins:*:*_declarativeVulnerableJenkins
cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:*3.11VulnerableRed Hat
  • cpe:2.3:a:jenkins:pipeline\:_declarative:*:*:*:*:*:jenkins:*:* Versions _declarative Vulnerable ·Jenkins
  • cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* Versions 3.11 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-x6jx-cxg3-mggh org.jenkinsci.plugins:pipeline-model-definition (Maven) Fixed in 1.3.4.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.10AffectedNo fix yet
Red Hat OpenShift Container Platform 3.5AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 3.6AffectedNo fix yet
Red Hat OpenShift Container Platform 3.7AffectedNo fix yet
Red Hat OpenShift Container Platform 3.9AffectedNo fix yet
Red Hat OpenShift Container Platform 3.11Fixed—
Not affected: 4 products
  • Red Hat OpenShift Container Platform 3.2
  • Red Hat OpenShift Container Platform 3.3
  • Red Hat OpenShift Container Platform 3.4
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1003002
  2. 2026-10-03 Alias added: GHSA-x6jx-cxg3-mggh

References

  • TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-15846 A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in… CVSS 3.1HIGH 8.8
  • TI-2023-11034 Cross-site scripting in Jenkins Pipeline: Build Step Plugin CVSS 3.1MEDIUM 5.4
  • TI-2019-15886 A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows… CVSS 3.1CRITICAL 9.8
  • TI-2022-21197 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin CVSS 3.1CRITICAL 9.9
  • TI-2022-08895 Protection mechanism failure in Jenkins Pipeline: Shared Groovy Libraries Plugin CVSS 3.1HIGH 8.8
See all 39 →

Sources