Protection mechanism failure in Jenkins Pipeline: Groovy Plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 4 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-693.
Summary
A sandbox bypass vulnerability involving various casts performed implicitly by the Groovy language runtime in Jenkins Pipeline: Groovy Plugin 2802.v5ea_628154b_c2 and earlier allows attackers with permission to define and run sandboxed scripts, including Pipelines, to bypass the sandbox protection and execute arbitrary code in the context of the Jenkins controller JVM.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Pipeline: Groovy Plugin | up to 2802.v5ea_628154b_c2 | 2759.2761.vd6e8d2a_15980, 2746.2748.v365128b_c26d7 | Patch available | CNA |
| — | org.jenkins-ci.plugins.workflow:workflow-cps (Maven) | before 2803.v1a_f77ffcc773 | 2803.v1a_f77ffcc773 | Patch available | GHSA-mqc2-w9r8-mmxm |
- Jenkins Pipeline: Groovy Plugin VendorJenkins Affected up to 2802.v5ea_628154b_c2 Fixed in 2759.2761.vd6e8d2a_15980, 2746.2748.v365128b_c26d7 Patch available CNA
- org.jenkins-ci.plugins.workflow:workflow-cps (Maven) Vendor— Affected before 2803.v1a_f77ffcc773 Fixed in 2803.v1a_f77ffcc773 Patch available GHSA-mqc2-w9r8-mmxm
Remediation
- Fix · CNA Jenkins Pipeline: Groovy Plugin (Jenkins project) Fixed in 2759.2761.vd6e8d2a_15980, 2746.2748.v365128b_c26d7
- Fix · GHSA-mqc2-w9r8-mmxm org.jenkins-ci.plugins.workflow:workflow-cps (Maven) Fixed in 2803.v1a_f77ffcc773 Advisory →
Red Hat 4 advisories
- RHSA-2023:3198 Released 2023-05-17 · Red Hat rating Criticaljenkins and jenkins-2-plugins security update
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 jenkins-2-plugins-4.11.1683009941-1.el8, jenkins-2.387.1.1683009763-3.el8
- RHSA-2023:1064 Released 2023-03-06 · Red Hat rating CriticalOpenShift Developer Tools and Services for OCP 4.12 security update
- OpenShift Developer Tools and Services for OCP 4.12 jenkins-2-plugins-4.12.1675702407-1.el8
- RHSA-2023:0777 Released 2023-02-23 · Red Hat rating CriticalOpenShift Container Platform 4.9.56 security update
- Red Hat OpenShift Container Platform 4.9 jenkins-2-plugins-4.9.1675668922-1.el8, jenkins-2.361.1.1675668150-1.el8
Show 1 more Red Hat advisories
- RHSA-2023:0560 Released 2023-02-08 · Red Hat rating CriticalOpenShift Container Platform 4.10.51 security update
- Red Hat OpenShift Container Platform 4.10 jenkins-2-plugins-4.10.1675144701-1.el8
Vendor assessments
Red Hat
Red Hat rating: Critical. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Out of support scope |
| OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 | Fixed | RHSA-2023:3198 |
| OpenShift Developer Tools and Services for OCP 4.12 | Fixed | RHSA-2023:1064 |
| Red Hat OpenShift Container Platform 4.10 | Fixed | RHSA-2023:0560 |
| Red Hat OpenShift Container Platform 4.9 | Fixed | RHSA-2023:0777 |
Not affected: 4 products
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8
- OpenShift Developer Tools and Services for OCP 4.12
- Red Hat OpenShift Container Platform 4.10
- Red Hat OpenShift Container Platform 4.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-43402
- 2026-10-03 Alias added: GHSA-mqc2-w9r8-mmxm
References
More Jenkins Pipeline vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15846 A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in… CVSS 3.1HIGH 8.8
- TI-2019-15847 A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier… CVSS 3.1HIGH 8.8
- TI-2023-11034 Cross-site scripting in Jenkins Pipeline: Build Step Plugin CVSS 3.1MEDIUM 5.4
- TI-2019-15886 A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2022-08895 Protection mechanism failure in Jenkins Pipeline: Shared Groovy Libraries Plugin CVSS 3.1HIGH 8.8
Sources
- CVE-2022-43402 · CVE Program
- CVE-2022-43402 · NVD
- FIRST EPSS
- GHSA-mqc2-w9r8-mmxm · GitHub Advisory Database · CC BY 4.0
- CVE-2022-43402 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences