Cross-site scripting in Moodle
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Moodle 3.8, messages required extra sanitizing before updating the conversation overview, to prevent the risk of stored cross-site scripting.
Why it matters now
EPSS 0.00649 51st percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.8.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Moodle | 3.8 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.8 to before 3.8.1 | 3.8.1 | Patch available | GHSA-cwhp-rqfr-8462 |
- Moodle Vendor— Affected 3.8 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.8 to before 3.8.1 Fixed in 3.8.1 Patch available GHSA-cwhp-rqfr-8462
Remediation
- Fix · GHSA-cwhp-rqfr-8462 moodle/moodle (Packagist) Fixed in 3.8.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-1691
- 2026-10-03 Alias added: GHSA-cwhp-rqfr-8462
- 2026-10-23 EPSS moved to the 50th–90th percentile
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2020-1691 · CVE Program
- CVE-2020-1691 · NVD
- FIRST EPSS
- GHSA-cwhp-rqfr-8462 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-1691 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences