Read the docs
TI-2020-01860 Aliases CVE-2020-1936GHSA-q7q9-w24q-cpgh

Stored XSS in Apache Ambari

Priority LOW 33CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A cross-site scripting issue was found in Apache Ambari Views. This was addressed in Apache Ambari 2.7.4.

Why it matters now

EPSS 0.02864 86th percentileScored 2026-11-07
Fix Fixed Apache Ambari (Apache Software Foundation): 2.7.4org.apache.ambari:ambari (Maven): 2.7.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache AmbariApache Ambari to before 2.7.42.7.4Patch availableCNA
—org.apache.ambari:ambari (Maven)before 2.7.42.7.4Patch availableGHSA-q7q9-w24q-cpgh
  • Apache Ambari VendorApache Affected Apache Ambari to before 2.7.4 Fixed in 2.7.4 Patch available CNA
  • org.apache.ambari:ambari (Maven) Vendor— Affected before 2.7.4 Fixed in 2.7.4 Patch available GHSA-q7q9-w24q-cpgh

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:ambari:*:*:*:*:*:*:*:*before 2.7.4VulnerableApache
  • cpe:2.3:a:apache:ambari:*:*:*:*:*:*:*:* Versions before 2.7.4 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Ambari (Apache Software Foundation) Fixed in 2.7.4
  • Fix · GHSA-q7q9-w24q-cpgh org.apache.ambari:ambari (Maven) Fixed in 2.7.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-1936
  2. 2026-10-03 Alias added: GHSA-q7q9-w24q-cpgh

References

  • TI-2016-05848 Improper access control in Apache Ambari CVSS 3.0CRITICAL 9.8
  • TI-2017-03642 During installation of Ambari 2.4.0 through 2.4.2, Ambari Server artifacts are not created with proper ACLs. CVSS 3.0CRITICAL 9.8
  • TI-2014-02906 In Ambari 1.2.0 through 2.2.2, it may be possible to execute arbitrary system commands on… CVSS 3.0CRITICAL 9.8
  • TI-2025-16981 Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition CVSS 3.1HIGH 8.8
  • TI-2024-34845 Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts CVSS 3.1HIGH 8.8
  • TI-2023-27565 Apache Ambari: authenticated users could perform command injection to perform RCE CVSS 3.1HIGH 8.8
See all 25 →

Sources