Insufficiently protected credentials in Jenkins Fortify Plugin
Priority LOW 21CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins Fortify Plugin 19.1.29 and earlier stores proxy server passwords unencrypted in job config.xml files on the Jenkins master where they can be viewed by users with Extended Read permission, or access to the master file system.
Why it matters now
EPSS 0.00647 51st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:fortify (Maven): 19.2.30
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Fortify Plugin | up to 19.1.29 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:fortify (Maven) | before 19.2.30 | 19.2.30 | Patch available | GHSA-xr37-pjfh-qwwc |
- Jenkins Fortify Plugin VendorJenkins Affected up to 19.1.29 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:fortify (Maven) Vendor— Affected before 19.2.30 Fixed in 19.2.30 Patch available GHSA-xr37-pjfh-qwwc
Remediation
- Fix · GHSA-xr37-pjfh-qwwc org.jenkins-ci.plugins:fortify (Maven) Fixed in 19.2.30 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2107
- 2026-10-03 Alias added: GHSA-xr37-pjfh-qwwc
- 2026-10-18 EPSS moved to the 50th–90th percentile
References
More Jenkins Fortify vulnerabilities
- TI-2023-03979 HTML injection vulnerability in Fortify Plugin CVSS 3.1MEDIUM 6.1
- TI-2023-03977 CSRF vulnerability in Fortify Plugin allow capturing credentials CVSS 3.1MEDIUM 5.4
- TI-2022-08901 Path traversal in Jenkins Fortify Plugin CVSS 3.1MEDIUM 4.3
- TI-2023-03978 Missing permission checks in Fortify Plugin allow capturing credentials CVSS 3.1MEDIUM 4.3
Sources
- CVE-2020-2107 · CVE Program
- CVE-2020-2107 · NVD
- FIRST EPSS
- GHSA-xr37-pjfh-qwwc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences