HTML injection vulnerability in Fortify Plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Fortify Plugin 22.1.38 and earlier does not escape the error message for a form validation method, resulting in an HTML injection vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Fortify Plugin | up to 22.1.38 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:fortify (Maven) | before 22.2.39 | 22.2.39 | Patch available | GHSA-223m-pgcq-f3xg |
- Jenkins Fortify Plugin VendorJenkins Affected up to 22.1.38 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:fortify (Maven) Vendor— Affected before 22.2.39 Fixed in 22.2.39 Patch available GHSA-223m-pgcq-f3xg
Remediation
- Fix · GHSA-223m-pgcq-f3xg org.jenkins-ci.plugins:fortify (Maven) Fixed in 22.2.39 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Jenkins Fortify Plugin — Jenkins Security Advisory 2023-08-16
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2023-03977 CSRF vulnerability in Fortify Plugin allow capturing credentialsPriority LOW 24
- TI-2023-03978 Missing permission checks in Fortify Plugin allow capturing credentialsPriority LOW 20
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4303
- 2026-10-03 Alias added: GHSA-223m-pgcq-f3xg
References
More Jenkins Fortify vulnerabilities
- TI-2023-03977 CSRF vulnerability in Fortify Plugin allow capturing credentials CVSS 3.1MEDIUM 5.4
- TI-2022-08901 Path traversal in Jenkins Fortify Plugin CVSS 3.1MEDIUM 4.3
- TI-2020-01984 Insufficiently protected credentials in Jenkins Fortify Plugin CVSS 3.1MEDIUM 4.3
- TI-2023-03978 Missing permission checks in Fortify Plugin allow capturing credentials CVSS 3.1MEDIUM 4.3
Sources
- CVE-2023-4303 · CVE Program
- CVE-2023-4303 · NVD
- FIRST EPSS
- GHSA-223m-pgcq-f3xg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences