Read the docs
TI-2023-03977 Aliases CVE-2023-4301GHSA-3fjv-8r82-6xm9

CSRF vulnerability in Fortify Plugin allow capturing credentials

Priority LOW 24CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

A cross-site request forgery (CSRF) vulnerability in Jenkins Fortify Plugin 22.1.38 and earlier allows attackers to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00224 13th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:fortify (Maven): 22.2.39

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Fortify Pluginup to 22.1.38—No fix listedCNA
—org.jenkins-ci.plugins:fortify (Maven)before 22.2.3922.2.39Patch availableGHSA-3fjv-8r82-6xm9
  • Jenkins Fortify Plugin VendorJenkins Affected up to 22.1.38 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:fortify (Maven) Vendor— Affected before 22.2.39 Fixed in 22.2.39 Patch available GHSA-3fjv-8r82-6xm9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:fortify:*:*:*:*:*:jenkins:*:*before 22.2.39VulnerableJenkins
  • cpe:2.3:a:jenkins:fortify:*:*:*:*:*:jenkins:*:* Versions before 22.2.39 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-3fjv-8r82-6xm9 org.jenkins-ci.plugins:fortify (Maven) Fixed in 22.2.39 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Jenkins Fortify Plugin — Jenkins Security Advisory 2023-08-16

    3 records Highest priority Priority LOW 3 LOW

    Other records, highest priority first

    • TI-2023-03979 HTML injection vulnerability in Fortify PluginPriority LOW 28
    • TI-2023-03978 Missing permission checks in Fortify Plugin allow capturing credentialsPriority LOW 20

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-4301
  2. 2026-10-03 Alias added: GHSA-3fjv-8r82-6xm9

References

  • TI-2023-03979 HTML injection vulnerability in Fortify Plugin CVSS 3.1MEDIUM 6.1
  • TI-2022-08901 Path traversal in Jenkins Fortify Plugin CVSS 3.1MEDIUM 4.3
  • TI-2020-01984 Insufficiently protected credentials in Jenkins Fortify Plugin CVSS 3.1MEDIUM 4.3
  • TI-2023-03978 Missing permission checks in Fortify Plugin allow capturing credentials CVSS 3.1MEDIUM 4.3

Sources