Denial of Service in uap-core when processing crafted User-Agent strings
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-1333.
Summary
uap-core before 0.7.3 is vulnerable to a denial of service attack when processing crafted User-Agent strings. Some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. This has been patched in uap-core 0.7.3.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ua-parser | uap-core | before 0.7.3 | 0.7.3 | Patch available | CNA |
| — | uap-core (npm) | before 0.7.3 | 0.7.3 | Patch available | GHSA-cmcx-xhr8-3w9p |
| — | user_agent_parser (RubyGems) | before 2.6.0 | 2.6.0 | Patch available | GHSA-cmcx-xhr8-3w9p |
- uap-core Vendorua-parser Affected before 0.7.3 Fixed in 0.7.3 Patch available CNA
- uap-core (npm) Vendor— Affected before 0.7.3 Fixed in 0.7.3 Patch available GHSA-cmcx-xhr8-3w9p
- user_agent_parser (RubyGems) Vendor— Affected before 2.6.0 Fixed in 2.6.0 Patch available GHSA-cmcx-xhr8-3w9p
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:uap-core_project:uap-core:*:*:*:*:*:node.js:*:* | before 0.7.3 | Vulnerable | Uap-core Project |
- cpe:2.3:a:uap-core_project:uap-core:*:*:*:*:*:node.js:*:* Versions before 0.7.3 Vulnerable ·Uap-core Project
Remediation
- Fix · CNA uap-core (ua-parser) Fixed in 0.7.3
- Fix · GHSA-cmcx-xhr8-3w9p uap-core (npm) Fixed in 0.7.3 Advisory →
- Fix · GHSA-cmcx-xhr8-3w9p user_agent_parser (RubyGems) Fixed in 2.6.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-5243
- 2026-10-03 Alias added: GHSA-cmcx-xhr8-3w9p
References
More ua-parser vulnerabilities
- TI-2018-14286 An issue was discovered in regex.yaml (aka regexes.yaml) in UA-Parser UAP-Core before… CVSS 3.0MEDIUM 5.3
- TI-2021-04417 Denial of Service in uap-core CVSS 3.1MEDIUM 5.3
Sources
- CVE-2020-5243 · CVE Program
- CVE-2020-5243 · NVD
- FIRST EPSS
- GHSA-cmcx-xhr8-3w9p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences