Denial of Service in uap-core
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
uap-core in an open-source npm package which contains the core of BrowserScope's original user agent string parser. In uap-core before version 0.11.0, some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. This is fixed in version 0.11.0. Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ua-parser | uap-core | before 0.11.0 | 0.11.0 | Patch available | CNA |
| — | uap-core (npm) | before 0.11.0 | 0.11.0 | Patch available | GHSA-p4pj-mg4r-x6v4 |
- uap-core Vendorua-parser Affected before 0.11.0 Fixed in 0.11.0 Patch available CNA
- uap-core (npm) Vendor— Affected before 0.11.0 Fixed in 0.11.0 Patch available GHSA-p4pj-mg4r-x6v4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:uap-core_project:uap-core:*:*:*:*:*:node.js:*:* | before 0.11.0 | Vulnerable | Uap-core Project |
- cpe:2.3:a:uap-core_project:uap-core:*:*:*:*:*:node.js:*:* Versions before 0.11.0 Vulnerable ·Uap-core Project
Remediation
- Fix · CNA uap-core (ua-parser) Fixed in 0.11.0
- Fix · GHSA-p4pj-mg4r-x6v4 uap-core (npm) Fixed in 0.11.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21317
- 2026-10-03 Alias added: GHSA-p4pj-mg4r-x6v4
References
Advisory 3
More ua-parser vulnerabilities
- TI-2020-04299 Denial of Service in uap-core when processing crafted User-Agent strings CVSS 3.1HIGH 7.5
- TI-2018-14286 An issue was discovered in regex.yaml (aka regexes.yaml) in UA-Parser UAP-Core before… CVSS 3.0MEDIUM 5.3
Sources
- CVE-2021-21317 · CVE Program
- CVE-2021-21317 · NVD
- FIRST EPSS
- GHSA-p4pj-mg4r-x6v4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences