Read the docs
TI-2020-04300 Aliases CVE-2020-5244GHSA-3j78-7m59-r7gv

Private data exposure via REST API in BuddyPress

Priority MEDIUM 40CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
High
Impact type
Security bypass, Information disclosure
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284 and CWE-200.

Summary

In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.

Why it matters now

EPSS 0.02443 84th percentileScored 2026-11-07
Fix Fixed BuddyPress (buddypress): 5.1.2buddypress/buddypress (Packagist): 5.1.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
buddypressBuddyPressbefore 5.1.25.1.2Patch availableCNA
—buddypress/buddypress (Packagist)before 5.1.25.1.2Patch availableGHSA-3j78-7m59-r7gv
  • BuddyPress Vendorbuddypress Affected before 5.1.2 Fixed in 5.1.2 Patch available CNA
  • buddypress/buddypress (Packagist) Vendor— Affected before 5.1.2 Fixed in 5.1.2 Patch available GHSA-3j78-7m59-r7gv

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:buddypress:buddypress:*:*:*:*:*:wordpress:*:*5.0.0 to before 5.1.2Vulnerablebuddypress
  • cpe:2.3:a:buddypress:buddypress:*:*:*:*:*:wordpress:*:* Versions 5.0.0 to before 5.1.2 Vulnerable ·buddypress

Remediation

  • Fix · CNA BuddyPress (buddypress) Fixed in 5.1.2
  • Fix · GHSA-3j78-7m59-r7gv buddypress/buddypress (Packagist) Fixed in 5.1.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-5244
  2. 2026-10-03 Alias added: GHSA-3j78-7m59-r7gv

References

  • TI-2021-04488 BuddyPress privilege escalation via REST API CVSS 3.1HIGH 8.8
  • TI-2014-01473 The Group creation process in the Buddypress plugin before 1.9.2 for WordPress allows… CVSS 3.0MEDIUM 6.5
  • TI-2024-09291 BuddyPress <= 14.1.0 - Authenticated (Subscriber+) Directory Traversal CVSS 3.1HIGH 8.1
  • TI-2012-01882 SQL injection vulnerability in wp-load.php in the BuddyPress plugin 1.5.x before 1.5.5 of… CVSS 2.0HIGH 7.5
  • TI-2025-17565 WordPress Mass Messaging in BuddyPress Plugin <= 2.2.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2024-03708 BuddyPress <= 12.4.0 - Authenticated (Subscriber+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
See all 10 →

Sources