BuddyPress privilege escalation via REST API
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| buddypress | BuddyPress | 5.0.0 to before 7.2.1 | 7.2.1 | Patch available | CNA |
| — | buddypress/buddypress (Packagist) | 5.0.0 to before 7.2.1 | 7.2.1 | Patch available | GHSA-m6j4-8r7p-wpp3 |
- BuddyPress Vendorbuddypress Affected 5.0.0 to before 7.2.1 Fixed in 7.2.1 Patch available CNA
- buddypress/buddypress (Packagist) Vendor— Affected 5.0.0 to before 7.2.1 Fixed in 7.2.1 Patch available GHSA-m6j4-8r7p-wpp3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:buddypress:buddypress:*:*:*:*:*:wordpress:*:* | 5.0.0 to before 7.2.1 | Vulnerable | buddypress |
- cpe:2.3:a:buddypress:buddypress:*:*:*:*:*:wordpress:*:* Versions 5.0.0 to before 7.2.1 Vulnerable ·buddypress
Remediation
- Fix · CNA BuddyPress (buddypress) Fixed in 7.2.1
- Fix · GHSA-m6j4-8r7p-wpp3 buddypress/buddypress (Packagist) Fixed in 7.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21389
- 2026-10-03 Alias added: GHSA-m6j4-8r7p-wpp3
References
Advisory 4
More Buddypress vulnerabilities
- TI-2014-01473 The Group creation process in the Buddypress plugin before 1.9.2 for WordPress allows… CVSS 3.0MEDIUM 6.5
- TI-2024-09291 BuddyPress <= 14.1.0 - Authenticated (Subscriber+) Directory Traversal CVSS 3.1HIGH 8.1
- TI-2020-04300 Private data exposure via REST API in BuddyPress CVSS 3.1HIGH 8.0
- TI-2012-01882 SQL injection vulnerability in wp-load.php in the BuddyPress plugin 1.5.x before 1.5.5 of… CVSS 2.0HIGH 7.5
- TI-2025-17565 WordPress Mass Messaging in BuddyPress Plugin <= 2.2.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-03708 BuddyPress <= 12.4.0 - Authenticated (Subscriber+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-21389 · CVE Program
- CVE-2021-21389 · NVD
- FIRST EPSS
- GHSA-m6j4-8r7p-wpp3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences