Read the docs

buddypress

Records20All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high12CVSS 7.0–8.9

Exploited now

buddypress records in CISA KEV

No buddypress vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

20 records

TI-2021-04488 CVE-2021-21389 · GHSA-m6j4-8r7p-wpp3

BuddyPress privilege escalation via REST API

Priority MEDIUM 54

BuddyPress is an open source WordPress plugin to build a community site.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.14811 Published 2021-03-26 Fixed in 7.2.1 CWE-863
Priority MEDIUM 40

In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed.

CVSS 3.1HIGH 8.0 Network No auth User interaction EPSS 0.02443 Published 2020-02-24 Fixed in 5.1.2 CWE-284
Priority LOW 39

BuddyPress 14.4.0 contains an insecure direct object reference vulnerability in the messages REST API that allows authenticated attackers to access arbitrary private message threads by supplying a user_id parameter in th…

CVSS 4.0HIGH 8.6 Network Low privileges No interaction EPSS 0.00371 Published 2026-06-09 Fixed in 14.5.0 CWE-639
Priority LOW 37

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in BuddyPress BuddyPress buddypress allows Blind SQL Injection.This issue affects BuddyPress: from n/a through 14.5.2.

CVSS 3.1HIGH 8.5 Network Low privileges No interaction EPSS 0.00289 Published 2026-10-29 No fix listed CWE-89
Priority LOW 37

The BuddyPress plugin for WordPress is vulnerable to Deserialization of Untrusted Data in all versions up to, and including, 14.5.0 This is due to the `bp_unserialize_profile_field()` function using `@unserialize()` with…

CVSS 3.1HIGH 7.5 Network Low privileges No interaction EPSS 0.01191 Published 2026-07-30 No fix listed CWE-502
TI-2026-81964 CVE-2026-111850 · GHSA-xvf7-fpqf-gg88

SQL injection in WordPress BuddyPress plugin

Priority LOW 36

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in BuddyPress BuddyPress buddypress allows SQL Injection.This issue affects BuddyPress: from n/a through 14.5.2.

CVSS 3.1HIGH 8.5 Network Low privileges No interaction EPSS 0.00211 Published 2026-10-28 No fix listed CWE-89
Priority LOW 31

BuddyPress 14.4.0 contains a regular expression injection vulnerability in the activity mention resolver that, when username compatibility mode is enabled, allows attackers to manipulate a REGEXP database clause by craft…

CVSS 4.0HIGH 7.1 Network Low privileges No interaction EPSS 0.00367 Published 2026-06-09 No fix listed CWE-943
Priority LOW 31

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ElbowRobo Mass Messaging in BuddyPress mass-messaging-in-buddypress allows Reflected XSS.This issue affects Mass Messa…

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.00316 Published 2025-01-22 No fix listed CWE-79
Priority LOW 29

The BuddyPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘user_name’ parameter in versions up to, and including, 12.4.0 due to insufficient input sanitization and output escaping.

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00439 Published 2024-05-09 No fix listed CWE-79
Priority LOW 29

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in The BuddyPress Community BuddyPress allows Stored XSS.This issue affects BuddyPress: from n/a through 11.3.1.

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.0036 Published 2023-12-29 No fix listed CWE-79
Priority LOW 28

The BuddyPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘display_name’ parameter in versions up to, and including, 12.4.1 due to insufficient input sanitization and output escaping.

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00362 Published 2024-06-12 No fix listed CWE-79
Priority LOW 25

Cross-site scripting (XSS) vulnerability in the BuddyPress plugin before 1.9.2 for WordPress allows remote authenticated users to inject arbitrary web script or HTML via the name field to groups/create/step/group-details…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.02577 Published 2014-02-28 No fix listed CWE-79
Priority LOW 23

BuddyPress 14.4.0 contains an insecure direct object reference vulnerability in the friends REST API that allows any authenticated attacker to enumerate another user's complete friend list.

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00227 Published 2026-06-09 No fix listed CWE-639
Priority LOW 20

The BuddyPress plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 14.3.3 via the bp_notifications_action_bulk_manage due to missing validation on a user controlle…

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00287 Published 2026-09-11 No fix listed CWE-862
Open these records in search →