Path traversal in Dell Integrated Dell Remote Access Controller
Priority LOW 35CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Dell EMC iDRAC9 versions prior to 4.20.20.20 contain a Path Traversal Vulnerability. A remote authenticated malicious user with low privileges could potentially exploit this vulnerability by manipulating input parameters to gain unauthorized read access to the arbitrary files.
Why it matters now
EPSS 0.01808 78th percentileScored 2026-11-07
Fix Fixed Integrated Dell Remote Access Controller (iDRAC) (Dell): 4.20.20.20
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | Integrated Dell Remote Access Controller (iDRAC) | before 4.20.20.20 | 4.20.20.20 | Patch available | CNA |
- Integrated Dell Remote Access Controller (iDRAC) VendorDell Affected before 4.20.20.20 Fixed in 4.20.20.20 Patch available CNA
Remediation
- Fix · CNA Integrated Dell Remote Access Controller (iDRAC) (Dell) Fixed in 4.20.20.20
Timeline
- 2026-10-02 Threatist record created from CVE-2020-5366
- 2026-10-03 Alias added: GHSA-jxmv-2677-8gm2
References
More Dell Idrac9 Firmware vulnerabilities
- TI-2020-04396 Stack-based buffer overflow in Dell Integrated Dell Remote Access Controller CVSS 3.1CRITICAL 9.8
- TI-2019-02726 Buffer overflow in Dell EMC iDRAC CVSS 3.1CRITICAL 9.8
- TI-2019-02728 WS-MAN Authentication Bypass Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2019-02727 Web Interface Authentication Bypass Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2021-04623 Improper authentication in Dell Integrated Dell Remote Access Controller CVSS 3.1CRITICAL 10.0
- TI-2018-01149 iDRAC7/iDRAC8/iDrac9 contains a command injection vulnerability in the SNMP agent. CVSS 3.0HIGH 8.8
Sources
- CVE-2020-5366 · CVE Program
- CVE-2020-5366 · NVD
- FIRST EPSS
- GHSA-jxmv-2677-8gm2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences