Cross-site scripting in SAP NetWeaver
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
SAP NetWeaver (Knowledge Management), versions - 7.30, 7.31, 7.40, 7.50, allows the automatic execution of script content in a stored file due to inadequate filtering with the accessing user's privileges. If the accessing user has administrative privileges, then the execution of the script content could result in complete compromise of system confidentiality, integrity and availability, leading to Stored Cross Site Scripting.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver (Knowledge Management) | before 7.30; before 7.31; before 7.40; before 7.50 | 7.30, 7.31, 7.40, 7.50 | Patch available | CNA |
- SAP NetWeaver (Knowledge Management) VendorSAP Affected before 7.30; before 7.31; before 7.40; before 7.50 Fixed in 7.30, 7.31, 7.40, 7.50 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_knowledge_management:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_knowledge_management:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_knowledge_management:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_knowledge_management:7.50:*:*:*:*:*:*:* | 7.50 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_knowledge_management:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_knowledge_management:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_knowledge_management:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_knowledge_management:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver (Knowledge Management) (SAP SE) Fixed in 7.30, 7.31, 7.40, 7.50
Timeline
- 2026-10-02 Threatist record created from CVE-2020-6284
- 2026-10-03 Alias added: GHSA-qh9g-xc58-f7h9
References
More SAP Netweaver Knowledge Management vulnerabilities
- TI-2021-04586 Deserialization of untrusted data in SAP NetWeaver Knowledge Management CVSS 3.1MEDIUM 6.5
- TI-2021-13081 Open redirect in SAP NetWeaver CVSS 3.1MEDIUM 6.1
- TI-2020-05145 Unrestricted file upload in SAP NetWeaver CVSS 3.1MEDIUM 6.5
- TI-2020-05050 Cross-site scripting in SAP NetWeaver CVSS 3.1MEDIUM 6.1
- TI-2020-05177 Cross-site scripting in SAP NetWeaver CVSS 3.1MEDIUM 5.4
Sources
- CVE-2020-6284 · CVE Program
- CVE-2020-6284 · NVD
- FIRST EPSS
- GHSA-qh9g-xc58-f7h9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences