Deserialization of untrusted data in SAP NetWeaver Knowledge Management
Priority LOW 32CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-502.
Summary
Knowledge Management versions 7.01, 7.02, 7.30, 7.31, 7.40, 7.50 allows a remote attacker with basic privileges to deserialize user-controlled data without verification, leading to insecure deserialization which triggers the attacker’s code, therefore impacting Availability.
Why it matters now
EPSS 0.01341 71st percentileScored 2026-11-07
Fix Fixed SAP NetWeaver Knowledge Management (SAP SE): 7.01, 7.02, 7.30 +3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver Knowledge Management | before 7.01; before 7.02; before 7.30; before 7.31; before 7.40; before 7.50 | 7.01, 7.02, 7.30, 7.31, 7.40, 7.50 | Patch available | CNA |
- SAP NetWeaver Knowledge Management VendorSAP Affected before 7.01; before 7.02; before 7.30; before 7.31; before 7.40; before 7.50 Fixed in 7.01, 7.02, 7.30, 7.31, 7.40, 7.50 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_knowledge_management:7.01:*:*:*:*:*:*:* | 7.01 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_knowledge_management:7.02:*:*:*:*:*:*:* | 7.02 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_knowledge_management:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_knowledge_management:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_knowledge_management:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_knowledge_management:7.50:*:*:*:*:*:*:* | 7.50 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_knowledge_management:7.01:*:*:*:*:*:*:* Versions 7.01 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_knowledge_management:7.02:*:*:*:*:*:*:* Versions 7.02 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_knowledge_management:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_knowledge_management:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_knowledge_management:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_knowledge_management:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver Knowledge Management (SAP SE) Fixed in 7.01, 7.02, 7.30, 7.31, 7.40, 7.50
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21488
- 2026-10-03 Alias added: GHSA-g2rh-3q72-5cq4
References
More SAP Netweaver Knowledge Management vulnerabilities
- TI-2020-05136 Cross-site scripting in SAP NetWeaver CVSS 3.1CRITICAL 9.0
- TI-2021-13081 Open redirect in SAP NetWeaver CVSS 3.1MEDIUM 6.1
- TI-2020-05145 Unrestricted file upload in SAP NetWeaver CVSS 3.1MEDIUM 6.5
- TI-2020-05050 Cross-site scripting in SAP NetWeaver CVSS 3.1MEDIUM 6.1
- TI-2020-05177 Cross-site scripting in SAP NetWeaver CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-21488 · CVE Program
- CVE-2021-21488 · NVD
- FIRST EPSS
- GHSA-g2rh-3q72-5cq4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences