Cross-site scripting in SAP NetWeaver
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
SAP NetWeaver (Knowledge Management), version-7.30,7.31,7.40,7.50, allows an authenticated attacker to create malicious links in the UI, when clicked by victim, will execute arbitrary java scripts thus extracting or modifying information otherwise restricted leading to Stored Cross Site Scripting.
Why it matters now
EPSS 0.00648 51st percentileScored 2026-11-07
Fix Fixed SAP NetWeaver (Knowledge Management) (SAP SE): 7.30, 7.31, 7.40 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver (Knowledge Management) | before 7.30; before 7.31; before 7.40; before 7.50 | 7.30, 7.31, 7.40, 7.50 | Patch available | CNA |
- SAP NetWeaver (Knowledge Management) VendorSAP Affected before 7.30; before 7.31; before 7.40; before 7.50 Fixed in 7.30, 7.31, 7.40, 7.50 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_knowledge_management:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_knowledge_management:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_knowledge_management:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_knowledge_management:7.50:*:*:*:*:*:*:* | 7.50 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_knowledge_management:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_knowledge_management:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_knowledge_management:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_knowledge_management:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver (Knowledge Management) (SAP SE) Fixed in 7.30, 7.31, 7.40, 7.50
Timeline
- 2026-10-02 Threatist record created from CVE-2020-6326
- 2026-10-03 Alias added: GHSA-vp93-pr49-f4r2
- 2026-10-18 EPSS moved to the 50th–90th percentile
References
More SAP Netweaver Knowledge Management vulnerabilities
- TI-2020-05136 Cross-site scripting in SAP NetWeaver CVSS 3.1CRITICAL 9.0
- TI-2021-04586 Deserialization of untrusted data in SAP NetWeaver Knowledge Management CVSS 3.1MEDIUM 6.5
- TI-2021-13081 Open redirect in SAP NetWeaver CVSS 3.1MEDIUM 6.1
- TI-2020-05145 Unrestricted file upload in SAP NetWeaver CVSS 3.1MEDIUM 6.5
- TI-2020-05050 Cross-site scripting in SAP NetWeaver CVSS 3.1MEDIUM 6.1
Sources
- CVE-2020-6326 · CVE Program
- CVE-2020-6326 · NVD
- FIRST EPSS
- GHSA-vp93-pr49-f4r2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences