Node.js < 12.18.4 and < 14.11 can be exploited to perform HTTP desync attacks and deliver…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 6 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
Node.js < 12.18.4 and < 14.11 can be exploited to perform HTTP desync attacks and deliver malicious payloads to unsuspecting users. The payloads can be crafted by an attacker to hijack user sessions, poison cookies, perform clickjacking, and a multitude of other attacks depending on the architecture of the underlying system. The attack was possible due to a bug in processing of carrier-return symbols in the HTTP header names.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | Node | 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 11.0 and later; 12.0 to before 12.18.4; 13.0 and later; 14.0 to before 14.11.0 | 12.18.4, 14.11.0 | Patch available | CNA |
- Node VendorNodeJS Affected 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 11.0 and later; 12.0 to before 12.18.4; 13.0 and later; 14.0 to before 14.11.0 Fixed in 12.18.4, 14.11.0 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* | 12.0.0 to before 12.18.4 | Vulnerable | NodeJS |
| cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:* | 14.0.0 to before 14.11.0 | Vulnerable | NodeJS |
| cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* | 15.2 | Vulnerable | openSUSE |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
- cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* Versions 12.0.0 to before 12.18.4 Vulnerable ·NodeJS
- cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:* Versions 14.0.0 to before 14.11.0 Vulnerable ·NodeJS
- cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Vulnerable ·openSUSE
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA Node (NodeJS) Fixed in 12.18.4, 14.11.0
Red Hat 3 advisories
- RHSA-2020:5086 Released 2020-11-12 · Red Hat rating Moderaterh-nodejs12-nodejs security update
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) rh-nodejs12-nodejs-12.18.4-3.el7, rh-nodejs12-nodejs-devel-12.18.4-3.el7, rh-nodejs12-nodejs-docs-12.18.4-3.el7 +1
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.6) rh-nodejs12-nodejs-12.18.4-3.el7, rh-nodejs12-nodejs-devel-12.18.4-3.el7, rh-nodejs12-nodejs-docs-12.18.4-3.el7 +1
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) rh-nodejs12-nodejs-12.18.4-3.el7, rh-nodejs12-nodejs-devel-12.18.4-3.el7, rh-nodejs12-nodejs-docs-12.18.4-3.el7 +1
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) rh-nodejs12-nodejs-12.18.4-3.el7, rh-nodejs12-nodejs-devel-12.18.4-3.el7, rh-nodejs12-nodejs-docs-12.18.4-3.el7 +1
- RHSA-2020:4903 Released 2020-11-04 · Red Hat rating Moderatenodejs:12 security and bug fix update
- Red Hat Enterprise Linux AppStream EUS (v. 8.1) nodejs-1:12.18.4-2.module+el8.1.0+8360+14141500.aarch64::nodejs:12, nodejs-1:12.18.4-2.module+el8.1.0+8360+14141500.ppc64le::nodejs:12, nodejs-1:12.18.4-2.module+el8.1.0+8360+14141500.s390x::nodejs:12 +19
- RHSA-2020:4272 Released 2020-10-19 · Red Hat rating Moderatenodejs:12 security and bug fix update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:12.18.4-2.module+el8.2.0+8361+192e434e.aarch64::nodejs:12, nodejs-1:12.18.4-2.module+el8.2.0+8361+192e434e.ppc64le::nodejs:12, nodejs-1:12.18.4-2.module+el8.2.0+8361+192e434e.s390x::nodejs:12 +19
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 8 | Affected | No fix yet |
| Red Hat Quay 3 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2020:4272 |
| Red Hat Enterprise Linux AppStream EUS (v. 8.1) | Fixed | RHSA-2020:4903 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2020:5086 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.6) | Fixed | RHSA-2020:5086 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) | Fixed | RHSA-2020:5086 |
| Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2020:5086 |
Not affected: 2 products
- Red Hat Enterprise Linux 8
- Red Hat Software Collections
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8201
- 2026-10-03 Alias added: GHSA-7mcp-gwc2-4c6m
References
More NodeJS Node.js vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
- TI-2022-03315 X.509 Email Address 4-byte Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2020-8201 · CVE Program
- CVE-2020-8201 · NVD
- FIRST EPSS
- GHSA-7mcp-gwc2-4c6m · GitHub Advisory Database · CC BY 4.0
- CVE-2020-8201 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences