A vulnerability exists in phpBB <v3.2.10 and <v3.3.1 which allowed remote image dimensions check to be used to SSRF.
Priority LOW 28CWE-610Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.
Summary
A vulnerability exists in phpBB <v3.2.10 and <v3.3.1 which allowed remote image dimensions check to be used to SSRF.
Why it matters now
EPSS 0.00966 61st percentileScored 2026-11-07
Fix Fixed phpbb/phpbb (Packagist): 3.2.10, 3.3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | https://github.com/phpbb/phpbb | 3.2.10 and 3.3.1 | — | No fix listed | CNA |
| — | phpbb/phpbb (Packagist) | 3.2.0 to before 3.2.10 | 3.2.10 | Patch available | GHSA-jhm9-h84h-rw83 |
| — | phpbb/phpbb (Packagist) | 3.3.0 to before 3.3.1 | 3.3.1 | Patch available | GHSA-jhm9-h84h-rw83 |
- https://github.com/phpbb/phpbb Vendor— Affected 3.2.10 and 3.3.1 Fixed in — No fix listed CNA
- phpbb/phpbb (Packagist) Vendor— Affected 3.2.0 to before 3.2.10 Fixed in 3.2.10 Patch available GHSA-jhm9-h84h-rw83
- phpbb/phpbb (Packagist) Vendor— Affected 3.3.0 to before 3.3.1 Fixed in 3.3.1 Patch available GHSA-jhm9-h84h-rw83
Remediation
- Fix · GHSA-jhm9-h84h-rw83 phpbb/phpbb (Packagist) Fixed in 3.2.10 Advisory →
- Fix · GHSA-jhm9-h84h-rw83 phpbb/phpbb (Packagist) Fixed in 3.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8226
- 2026-10-03 Alias added: GHSA-jhm9-h84h-rw83
References
Patch 2
More Phpbb vulnerabilities
- TI-2025-43137 Cross Site Request Forgery vulnerability in Phpbb phbb3 v.3.3.15 allows a local attacker… CVSS 3.1HIGH 8.8
- TI-2001-01423 prefs.php in phpBB 1.4.0 and earlier allows remote authenticated users to execute… CVSS 3.1HIGH 8.8
- TI-2008-03086 Unspecified vulnerability in phpBB before 3.0.1 has unknown impact and attack vectors… CVSS 2.0HIGH 10.0
- TI-2008-01694 Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack… CVSS 2.0HIGH 10.0
- TI-2006-06909 PHP remote file inclusion vulnerability in includes/not_mem.php in the Add Name module… CVSS 2.0HIGH 7.5
- TI-2019-12678 In phpBB before 3.1.7-PL1, includes/acp/acp_bbcodes.php has improper verification of a… CVSS 3.1HIGH 8.8
Sources
- CVE-2020-8226 · CVE Program
- CVE-2020-8226 · NVD
- FIRST EPSS
- GHSA-jhm9-h84h-rw83 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences