Improper input validation in [UNKNOWN] moodle
Priority MEDIUM 44CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
A flaw was found in Moodle versions 3.8 before 3.8.3, 3.7 before 3.7.6, 3.6 before 3.6.10, 3.5 before 3.5.12 and earlier unsupported versions. It was possible to create a SCORM package in such a way that when added to a course, it could be interacted with via web services in order to achieve remote code execution.
Why it matters now
EPSS 0.02999 87th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.8.3, 3.7.6, 3.6.10 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| [UNKNOWN] | moodle | 3.8 to 3.8.2; 3.7 to 3.7.5; 3.6 to 3.6.9; 3.5 to 3.5.11; Earlier unsupported versions. | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.8 to before 3.8.3 | 3.8.3 | Patch available | GHSA-vr6v-g96p-cjc3 |
| — | moodle/moodle (Packagist) | 3.7 to before 3.7.6 | 3.7.6 | Patch available | GHSA-vr6v-g96p-cjc3 |
| — | moodle/moodle (Packagist) | 3.6 to before 3.6.10 | 3.6.10 | Patch available | GHSA-vr6v-g96p-cjc3 |
| — | moodle/moodle (Packagist) | 3.5 to before 3.5.12 | 3.5.12 | Patch available | GHSA-vr6v-g96p-cjc3 |
- moodle Vendor[UNKNOWN] Affected 3.8 to 3.8.2; 3.7 to 3.7.5; 3.6 to 3.6.9; 3.5 to 3.5.11; Earlier unsupported versions. Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.8 to before 3.8.3 Fixed in 3.8.3 Patch available GHSA-vr6v-g96p-cjc3
- moodle/moodle (Packagist) Vendor— Affected 3.7 to before 3.7.6 Fixed in 3.7.6 Patch available GHSA-vr6v-g96p-cjc3
- moodle/moodle (Packagist) Vendor— Affected 3.6 to before 3.6.10 Fixed in 3.6.10 Patch available GHSA-vr6v-g96p-cjc3
- moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.12 Fixed in 3.5.12 Patch available GHSA-vr6v-g96p-cjc3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.5 to before 3.5.12; 3.6 to before 3.6.10; 3.7 to before 3.7.6; 3.8 to before 3.8.3 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.5 to before 3.5.12; 3.6 to before 3.6.10; 3.7 to before 3.7.6; 3.8 to before 3.8.3 Vulnerable ·Moodle
Remediation
- Fix · GHSA-vr6v-g96p-cjc3 moodle/moodle (Packagist) Fixed in 3.8.3 Advisory →
- Fix · GHSA-vr6v-g96p-cjc3 moodle/moodle (Packagist) Fixed in 3.7.6 Advisory →
- Fix · GHSA-vr6v-g96p-cjc3 moodle/moodle (Packagist) Fixed in 3.6.10 Advisory →
- Fix · GHSA-vr6v-g96p-cjc3 moodle/moodle (Packagist) Fixed in 3.5.12 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-10738
- 2026-10-03 Alias added: GHSA-vr6v-g96p-cjc3
References
Patch 3
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2020-10738 · CVE Program
- CVE-2020-10738 · NVD
- FIRST EPSS
- GHSA-vr6v-g96p-cjc3 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-10738 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences