Negative charge in shopping cart possible in Shopizer
Priority LOW 30CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
In Shopizer before version 2.11.0, using API or Controller based versions negative quantity is not adequately validated hence creating incorrect shopping cart and order total. This vulnerability makes it possible to create a negative total in the shopping cart. This has been patched in version 2.11.0.
Why it matters now
EPSS 0.00852 58th percentileScored 2026-11-07
Fix Fixed shopizer (shopizer-ecommerce): 2.11.0com.shopizer:sm-core-model (Maven): 2.11.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| shopizer-ecommerce | shopizer | before 2.11.0 | 2.11.0 | Patch available | CNA |
| — | com.shopizer:sm-core-model (Maven) | before 2.11.0 | 2.11.0 | Patch available | GHSA-w8rc-pgxq-x2cj |
- shopizer Vendorshopizer-ecommerce Affected before 2.11.0 Fixed in 2.11.0 Patch available CNA
- com.shopizer:sm-core-model (Maven) Vendor— Affected before 2.11.0 Fixed in 2.11.0 Patch available GHSA-w8rc-pgxq-x2cj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:shopizer:shopizer:*:*:*:*:*:*:*:* | before 2.11.0 | Vulnerable | shopizer-ecommerce |
- cpe:2.3:a:shopizer:shopizer:*:*:*:*:*:*:*:* Versions before 2.11.0 Vulnerable ·shopizer-ecommerce
Remediation
- Fix · CNA shopizer (shopizer-ecommerce) Fixed in 2.11.0
- Fix · GHSA-w8rc-pgxq-x2cj com.shopizer:sm-core-model (Maven) Fixed in 2.11.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-11007
- 2026-10-03 Alias added: GHSA-w8rc-pgxq-x2cj
References
More shopizer-ecommerce Shopizer vulnerabilities
- TI-2025-32372 An issue was discovered in Shopizer 3.2.7. CVSS 3.1HIGH 8.1
- TI-2022-07236 Shopizer - Insufficient Session Expiration CVSS 3.1HIGH 8.8
- TI-2020-08880 Potential remote code execution in Shopizer CVSS 3.1CRITICAL 9.1
- TI-2014-04073 Shopizer 1.1.5 and earlier allows remote attackers to modify the account settings of… CVSS 2.0MEDIUM 6.8
- TI-2014-04072 Shopizer 1.1.5 and earlier allows remote attackers to reduce the total cost of their… CVSS 2.0MEDIUM 6.4
- TI-2014-04074 Multiple cross-site request forgery (CSRF) vulnerabilities in Shopizer 1.1.5 and earlier… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2020-11007 · CVE Program
- CVE-2020-11007 · NVD
- FIRST EPSS
- GHSA-w8rc-pgxq-x2cj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences