Read the docs

shopizer-ecommerce

Records15All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical1CVSS 9.0–10.0
CVSS high2CVSS 7.0–8.9

Exploited now

shopizer-ecommerce records in CISA KEV

No shopizer-ecommerce vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

15 records

Priority MEDIUM 57

Shopizer through 3.2.5 contains an authorization bypass vulnerability that allows authenticated customers to post reviews as other customers by supplying a customerId field.

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00223 Published 2026-10-14 No fix listed CWE-639
TI-2022-07236 CVE-2022-23063 · GHSA-55c7-jcxx-6jxx

Shopizer - Insufficient Session Expiration

Priority MEDIUM 41

In Shopizer versions 2.3.0 to 3.0.1 are vulnerable to Insufficient Session Expiration.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01232 Published 2022-05-03 No fix listed CWE-613
Priority MEDIUM 40

In Shopizer before version 2.11.0, a script can be injected in various forms and saved in the database, then executed when information is fetched from backend.

CVSS 3.1CRITICAL 9.1 Network Low privileges No interaction EPSS 0.0063 Published 2020-05-08 Fixed in 2.11.0 CWE-79
TI-2022-07235 CVE-2022-23061 · GHSA-wf9v-5m62-rw7r

Shopizer - IDOR delete superadmin

Priority LOW 31

In Shopizer versions 2.0 to 2.17.0 a regular admin can permanently delete a superadmin (although this cannot happen according to the documentation) via Insecure Direct Object Reference (IDOR) vulnerability.

CVSS 3.1MEDIUM 6.5 Network High privileges No interaction EPSS 0.01131 Published 2022-05-01 No fix listed CWE-639
Priority LOW 30

In Shopizer before version 2.11.0, using API or Controller based versions negative quantity is not adequately validated hence creating incorrect shopping cart and order total.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00852 Published 2020-04-16 Fixed in 2.11.0 CWE-20
Priority LOW 27

A reflected cross-site scripting (XSS) vulnerability in Shopizer before 2.17.0 allows remote attackers to inject arbitrary web script or HTML via the ref parameter to a page about an arbitrary product, e.g., a product/in…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.02916 Published 2021-05-24 Fixed in 2.17.0 CWE-79
TI-2022-07234 CVE-2022-23060 · GHSA-r7gr-rcg6-hxhr

Shopizer - Stored XSS in Manage Files

Priority LOW 23

A Stored Cross Site Scripting (XSS) vulnerability exists in Shopizer versions 2.0 through 2.17.0, where a privileged user (attacker) can inject malicious JavaScript in the filename under the “Manage files” tab

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00624 Published 2022-05-01 No fix listed CWE-79
TI-2022-07233 CVE-2022-23059 · GHSA-p2j7-6g9h-32xh

Shopizer - Stored XSS in Manage Images

Priority LOW 23

A Stored Cross Site Scripting (XSS) vulnerability exists in Shopizer versions 2.0 through 2.17.0 via the “Manage Images” tab, which allows an attacker to upload a SVG file containing malicious JavaScript code.

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00624 Published 2022-03-29 Fixed in 3.0.0 CWE-79
Open these records in search →