SQL injection in Apache SkyWalking
Priority HIGH 67CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
**Resolved** Only when using H2/MySQL/TiDB as Apache SkyWalking storage, there is a SQL injection vulnerability in the wildcard query cases.
Why it matters now
EPSS 0.33478 98th percentileScored 2026-11-07
Fix Fixed org.apache.skywalking:oap-server (Maven): 8.1.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Apache SkyWalking | Apache SkyWalking 6.5.0, 6.6.0, 7.0.0, 8.0.0, 8.0.1 | — | No fix listed | CNA |
| — | org.apache.skywalking:oap-server (Maven) | before 8.1.0 | 8.1.0 | Patch available | GHSA-grpf-gg7v-5g5h |
- Apache SkyWalking Vendor— Affected Apache SkyWalking 6.5.0, 6.6.0, 7.0.0, 8.0.0, 8.0.1 Fixed in — No fix listed CNA
- org.apache.skywalking:oap-server (Maven) Vendor— Affected before 8.1.0 Fixed in 8.1.0 Patch available GHSA-grpf-gg7v-5g5h
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:skywalking:6.5.0:*:*:*:*:*:*:* | 6.5.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:skywalking:6.6.0:*:*:*:*:*:*:* | 6.6.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:skywalking:7.0.0:*:*:*:*:*:*:* | 7.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:skywalking:8.0.0:*:*:*:*:*:*:* | 8.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:skywalking:8.0.1:*:*:*:*:*:*:* | 8.0.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:skywalking:6.5.0:*:*:*:*:*:*:* Versions 6.5.0 Vulnerable ·Apache
- cpe:2.3:a:apache:skywalking:6.6.0:*:*:*:*:*:*:* Versions 6.6.0 Vulnerable ·Apache
- cpe:2.3:a:apache:skywalking:7.0.0:*:*:*:*:*:*:* Versions 7.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:skywalking:8.0.0:*:*:*:*:*:*:* Versions 8.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:skywalking:8.0.1:*:*:*:*:*:*:* Versions 8.0.1 Vulnerable ·Apache
Remediation
- Fix · GHSA-grpf-gg7v-5g5h org.apache.skywalking:oap-server (Maven) Fixed in 8.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-13921
- 2026-10-03 Alias added: GHSA-grpf-gg7v-5g5h
References
Advisory 3
Other 5
- [skywalking-dev] 20200805 Subject: [CVE-2020-13921] Apache SkyWalking SQL injection vulnerability after H2/MySQL/TiDB storage option activated.
- https://github.com/apache/skywalking/commit/fb7912c6bdda06a233f4b3e18e71a87d3e4a8951
- https://github.com/apache/skywalking
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-skywalking/PYSEC-2020-342.yaml
- https://lists.apache.org/thread.html/r6f3a934ebc54585d8468151a494c1919dc1ee2cccaf237ec434dbbd6@%3Cdev.skywalking.apache.org%3E
More Apache Skywalking vulnerabilities
- TI-2020-07592 SQL injection in Apache SkyWalking CVSS 3.1HIGH 7.5
- TI-2026-23619 Apache SkyWalking: The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive… CVSS 3.1HIGH 7.5
- TI-2025-33902 Apache SkyWalking: Stored XSS vulnerability CVSS 3.1MEDIUM 6.1
Sources
- CVE-2020-13921 · CVE Program
- CVE-2020-13921 · NVD
- FIRST EPSS
- GHSA-grpf-gg7v-5g5h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences