Apache SkyWalking: The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive…
Priority MEDIUM 40CWE-202Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information of MySQL/PostgreSQL. This issue affects Apache SkyWalking: from 9.7.0 through 10.3.0. Users are recommended to upgrade to version 10.4.0, which fixes the issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00544 45th percentileScored 2026-11-07
Fix Fixed org.apache.skywalking:server-core (Maven): 10.4.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache SkyWalking | 9.7.0 – 10.3.0 | — | No fix listed | CNA |
| — | org.apache.skywalking:server-core (Maven) | 9.7.0 to before 10.4.0 | 10.4.0 | Patch available | GHSA-27h3-crw2-q36w |
- Apache SkyWalking VendorApache Affected 9.7.0 – 10.3.0 Fixed in — No fix listed CNA
- org.apache.skywalking:server-core (Maven) Vendor— Affected 9.7.0 to before 10.4.0 Fixed in 10.4.0 Patch available GHSA-27h3-crw2-q36w
Remediation
- Fix · GHSA-27h3-crw2-q36w org.apache.skywalking:server-core (Maven) Fixed in 10.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-30778
- 2026-10-03 Alias added: GHSA-27h3-crw2-q36w
References
Advisory 3
More Apache Skywalking vulnerabilities
- TI-2020-10899 SQL injection in Apache SkyWalking CVSS 3.1CRITICAL 9.8
- TI-2020-07592 SQL injection in Apache SkyWalking CVSS 3.1HIGH 7.5
- TI-2025-33902 Apache SkyWalking: Stored XSS vulnerability CVSS 3.1MEDIUM 6.1
Sources
- CVE-2026-30778 · CVE Program
- CVE-2026-30778 · NVD
- FIRST EPSS
- GHSA-27h3-crw2-q36w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences