Apache SkyWalking: Stored XSS vulnerability
Priority LOW 29CWE-80Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-80.
Summary
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache SkyWalking. This issue affects Apache SkyWalking: <= 10.2.0. Users are recommended to upgrade to version 10.3.0, which fixes the issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00794 56th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache SkyWalking | up to 10.2.0 | — | No fix listed | CNA |
| — | org.apache.skywalking:apm-webapp (Maven) | up to 10.1.0 | — | No fix listed | GHSA-v6x2-4q87-rf82 |
- Apache SkyWalking VendorApache Affected up to 10.2.0 Fixed in — No fix listed CNA
- org.apache.skywalking:apm-webapp (Maven) Vendor— Affected up to 10.1.0 Fixed in — No fix listed GHSA-v6x2-4q87-rf82
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-54057
- 2026-10-03 Alias added: GHSA-v6x2-4q87-rf82
References
More Apache Skywalking vulnerabilities
- TI-2020-10899 SQL injection in Apache SkyWalking CVSS 3.1CRITICAL 9.8
- TI-2020-07592 SQL injection in Apache SkyWalking CVSS 3.1HIGH 7.5
- TI-2026-23619 Apache SkyWalking: The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive… CVSS 3.1HIGH 7.5
Sources
- CVE-2025-54057 · CVE Program
- CVE-2025-54057 · NVD
- FIRST EPSS
- GHSA-v6x2-4q87-rf82 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences