In PowerDNS Recursor versions up to and including 4.3.1, 4.2.2 and 4.1.16, the ACL…
Priority LOW 27CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.
Summary
In PowerDNS Recursor versions up to and including 4.3.1, 4.2.2 and 4.1.16, the ACL restricting access to the internal web server is not properly enforced.
Why it matters now
EPSS 0.01696 77th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-14196
- 2026-10-03 Alias added: GHSA-fqf5-f2p3-h3j2
References
More PowerDNS Recursor vulnerabilities
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
- TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
- TI-2017-11091 NULL pointer dereference in PowerDNS pdns-recursor CVSS 3.0HIGH 7.5
- TI-2014-07065 PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2020-14196 · CVE Program
- CVE-2020-14196 · NVD
- FIRST EPSS
- GHSA-fqf5-f2p3-h3j2 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-14196 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences