Read the docs
TI-2020-11191 Aliases CVE-2020-14320GHSA-fcpw-vqh5-6qwj

Cross-site scripting in Moodle

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

In Moodle before 3.9.1, 3.8.4 and 3.7.7, the filter in the admin task log required extra sanitizing to prevent a reflected XSS risk.

Why it matters now

EPSS 0.0072 54th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.1, 3.8.4, 3.7.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—MoodleMoodle 3.9, 3.8 to 3.8.3 and 3.7 to 3.7.6—No fix listedCNA
—moodle/moodle (Packagist)3.9 to before 3.9.13.9.1Patch availableGHSA-fcpw-vqh5-6qwj
—moodle/moodle (Packagist)3.8 to before 3.8.43.8.4Patch availableGHSA-fcpw-vqh5-6qwj
—moodle/moodle (Packagist)3.7 to before 3.7.73.7.7Patch availableGHSA-fcpw-vqh5-6qwj
  • Moodle Vendor— Affected Moodle 3.9, 3.8 to 3.8.3 and 3.7 to 3.7.6 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.1 Fixed in 3.9.1 Patch available GHSA-fcpw-vqh5-6qwj
  • moodle/moodle (Packagist) Vendor— Affected 3.8 to before 3.8.4 Fixed in 3.8.4 Patch available GHSA-fcpw-vqh5-6qwj
  • moodle/moodle (Packagist) Vendor— Affected 3.7 to before 3.7.7 Fixed in 3.7.7 Patch available GHSA-fcpw-vqh5-6qwj

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.7.0 to before 3.7.7; 3.8.0 to before 3.8.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.9.0:-:*:*:*:*:*:*3.9.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.7.0 to before 3.7.7; 3.8.0 to before 3.8.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.9.0:-:*:*:*:*:*:* Versions 3.9.0 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-fcpw-vqh5-6qwj moodle/moodle (Packagist) Fixed in 3.9.1 Advisory →
  • Fix · GHSA-fcpw-vqh5-6qwj moodle/moodle (Packagist) Fixed in 3.8.4 Advisory →
  • Fix · GHSA-fcpw-vqh5-6qwj moodle/moodle (Packagist) Fixed in 3.7.7 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-14320
  2. 2026-10-03 Alias added: GHSA-fcpw-vqh5-6qwj

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources