Incorrect authorization in Moodle
Priority MEDIUM 54CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, teachers of a course were able to assign themselves the manager role within that course.
Why it matters now
EPSS 0.15993 96th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.1, 3.8.4, 3.7.7 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Moodle | Moodle 3.9, 3.8 to 3.8.3, 3.7 to 3.7.6, 3.5 to 3.5.12 and earlier unsupported versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.9.0-beta to before 3.9.1 | 3.9.1 | Patch available | GHSA-9q29-jcjw-fw7h |
| — | moodle/moodle (Packagist) | 3.8.0-beta to before 3.8.4 | 3.8.4 | Patch available | GHSA-9q29-jcjw-fw7h |
| — | moodle/moodle (Packagist) | 3.6.0-beta to before 3.7.7 | 3.7.7 | Patch available | GHSA-9q29-jcjw-fw7h |
| — | moodle/moodle (Packagist) | before 3.5.13 | 3.5.13 | Patch available | GHSA-9q29-jcjw-fw7h |
- Moodle Vendor— Affected Moodle 3.9, 3.8 to 3.8.3, 3.7 to 3.7.6, 3.5 to 3.5.12 and earlier unsupported versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.9.0-beta to before 3.9.1 Fixed in 3.9.1 Patch available GHSA-9q29-jcjw-fw7h
- moodle/moodle (Packagist) Vendor— Affected 3.8.0-beta to before 3.8.4 Fixed in 3.8.4 Patch available GHSA-9q29-jcjw-fw7h
- moodle/moodle (Packagist) Vendor— Affected 3.6.0-beta to before 3.7.7 Fixed in 3.7.7 Patch available GHSA-9q29-jcjw-fw7h
- moodle/moodle (Packagist) Vendor— Affected before 3.5.13 Fixed in 3.5.13 Patch available GHSA-9q29-jcjw-fw7h
Remediation
- Fix · GHSA-9q29-jcjw-fw7h moodle/moodle (Packagist) Fixed in 3.9.1 Advisory →
- Fix · GHSA-9q29-jcjw-fw7h moodle/moodle (Packagist) Fixed in 3.8.4 Advisory →
- Fix · GHSA-9q29-jcjw-fw7h moodle/moodle (Packagist) Fixed in 3.7.7 Advisory →
- Fix · GHSA-9q29-jcjw-fw7h moodle/moodle (Packagist) Fixed in 3.5.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-14321
- 2026-10-03 Alias added: GHSA-9q29-jcjw-fw7h
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2020-14321 · CVE Program
- CVE-2020-14321 · NVD
- FIRST EPSS
- GHSA-9q29-jcjw-fw7h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences