x87 FPU operations in enclaves are vulnerable to ABI poisoning in openenclave
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In openenclave before 0.10.0, enclaves that use x87 FPU operations are vulnerable to tampering by a malicious host application. By violating the Linux System V Application Binary Interface (ABI) for such operations, a host app can compromise the execution integrity of some x87 FPU operations in an enclave. Depending on the FPU control configuration of the enclave app and whether the operations are used in secret-dependent execution paths, this vulnerability may also be used to mount a side-channel attack on the enclave. This has been fixed in 0.10.0 and the current master branch. Users will need to recompile their applications against the patched libraries to be protected from this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| openenclave | openenclave | before 0.10.0 | 0.10.0 | Patch available | CNA |
- openenclave Vendoropenenclave Affected before 0.10.0 Fixed in 0.10.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openenclave:openenclave:*:*:*:*:*:*:*:* | before 0.10.0 | Vulnerable | openenclave |
- cpe:2.3:a:openenclave:openenclave:*:*:*:*:*:*:*:* Versions before 0.10.0 Vulnerable ·openenclave
Remediation
- Fix · CNA openenclave (openenclave) Fixed in 0.10.0
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15107
References
More Openenclave vulnerabilities
- TI-2023-19087 Improper sanitization of MXCSR and RFLAGS in OpenEnclave CVSS 3.1HIGH 7.5
- TI-2020-11996 Socket syscalls can leak enclave memory contents in Open Enclave CVSS 3.1MEDIUM 6.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences