Socket syscalls can leak enclave memory contents in Open Enclave
Key facts
- Attack vector
- Adjacent network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-552.
Summary
In Open Enclave before version 0.12.0, an information disclosure vulnerability exists when an enclave application using the syscalls provided by the sockets.edl is loaded by a malicious host application. An attacker who successfully exploited the vulnerability could read privileged data from the enclave heap across trust boundaries. To exploit this vulnerability, an attacker would have to log on to an affected system and run a specially crafted application. The vulnerability would not allow an attacker to elevate user rights directly, but it could be used to obtain information otherwise considered confidential in an enclave, which could be used in further compromises. The issue has been addressed in version 0.12.0 and the current master branch. Users will need to to recompile their applications against the patched libraries to be protected from this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| openenclave | openenclave | before 0.12.0 | 0.12.0 | Patch available | CNA |
- openenclave Vendoropenenclave Affected before 0.12.0 Fixed in 0.12.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openenclave:openenclave:*:*:*:*:*:*:*:* | before 0.12.0 | Vulnerable | openenclave |
- cpe:2.3:a:openenclave:openenclave:*:*:*:*:*:*:*:* Versions before 0.12.0 Vulnerable ·openenclave
Remediation
- Fix · CNA openenclave (openenclave) Fixed in 0.12.0
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15224
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
More Openenclave vulnerabilities
- TI-2023-19087 Improper sanitization of MXCSR and RFLAGS in OpenEnclave CVSS 3.1HIGH 7.5
- TI-2020-11882 x87 FPU operations in enclaves are vulnerable to ABI poisoning in openenclave CVSS 3.1MEDIUM 5.3
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences