Read the docs
TI-2020-11966 Aliases CVE-2020-15194GHSA-9mqp-7v2h-2382

Denial of Service in Tensorflow

Priority LOW 26CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-617.

Summary

In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, the `SparseFillEmptyRowsGrad` implementation has incomplete validation of the shapes of its arguments. Although `reverse_index_map_t` and `grad_values_t` are accessed in a similar pattern, only `reverse_index_map_t` is validated to be of proper shape. Hence, malicious users can pass a bad `grad_values_t` to trigger an assertion failure in `vec`, causing denial of service in serving installations. The issue is patched in commit 390611e0d45c5793c7066110af37c8514e6a6c54, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1."

Why it matters now

EPSS 0.01026 63rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (tensorflow): 1.15.4, 2.0.3, 2.1.2 +2tensorflow (PyPI): 1.15.4, 2.0.3, 2.1.2 +2+2 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflowbefore 1.15.4; 2.0.0 to before 2.0.3; 2.1.0 to before 2.1.2; 2.2.0 to before 2.2.1; 2.3.0 to before 2.3.11.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1Patch availableCNA
—tensorflow (PyPI)before 1.15.41.15.4Patch availableGHSA-9mqp-7v2h-2382
—tensorflow (PyPI)2.0.0 to before 2.0.32.0.3Patch availableGHSA-9mqp-7v2h-2382
—tensorflow (PyPI)2.1.0 to before 2.1.22.1.2Patch availableGHSA-9mqp-7v2h-2382
—tensorflow (PyPI)2.2.0 to before 2.2.12.2.1Patch availableGHSA-9mqp-7v2h-2382
—tensorflow (PyPI)2.3.0 to before 2.3.12.3.1Patch availableGHSA-9mqp-7v2h-2382
—tensorflow-cpu (PyPI)before 1.15.41.15.4Patch availableGHSA-9mqp-7v2h-2382
—tensorflow-cpu (PyPI)2.0.0 to before 2.0.32.0.3Patch availableGHSA-9mqp-7v2h-2382
—tensorflow-cpu (PyPI)2.1.0 to before 2.1.22.1.2Patch availableGHSA-9mqp-7v2h-2382
—tensorflow-cpu (PyPI)2.2.0 to before 2.2.12.2.1Patch availableGHSA-9mqp-7v2h-2382
—tensorflow-cpu (PyPI)2.3.0 to before 2.3.12.3.1Patch availableGHSA-9mqp-7v2h-2382
—tensorflow-gpu (PyPI)before 1.15.41.15.4Patch availableGHSA-9mqp-7v2h-2382
—tensorflow-gpu (PyPI)2.0.0 to before 2.0.32.0.3Patch availableGHSA-9mqp-7v2h-2382
—tensorflow-gpu (PyPI)2.1.0 to before 2.1.22.1.2Patch availableGHSA-9mqp-7v2h-2382
—tensorflow-gpu (PyPI)2.2.0 to before 2.2.12.2.1Patch availableGHSA-9mqp-7v2h-2382
—tensorflow-gpu (PyPI)2.3.0 to before 2.3.12.3.1Patch availableGHSA-9mqp-7v2h-2382
  • tensorflow VendorGoogle Affected before 1.15.4; 2.0.0 to before 2.0.3; 2.1.0 to before 2.1.2; 2.2.0 to before 2.2.1; 2.3.0 to before 2.3.1 Fixed in 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 1.15.4 Fixed in 1.15.4 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow (PyPI) Vendor— Affected 2.0.0 to before 2.0.3 Fixed in 2.0.3 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow (PyPI) Vendor— Affected 2.1.0 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow (PyPI) Vendor— Affected 2.2.0 to before 2.2.1 Fixed in 2.2.1 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow-cpu (PyPI) Vendor— Affected before 1.15.4 Fixed in 1.15.4 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow-cpu (PyPI) Vendor— Affected 2.0.0 to before 2.0.3 Fixed in 2.0.3 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow-cpu (PyPI) Vendor— Affected 2.1.0 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow-cpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.1 Fixed in 2.2.1 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow-cpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow-gpu (PyPI) Vendor— Affected before 1.15.4 Fixed in 1.15.4 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow-gpu (PyPI) Vendor— Affected 2.0.0 to before 2.0.3 Fixed in 2.0.3 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow-gpu (PyPI) Vendor— Affected 2.1.0 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow-gpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.1 Fixed in 2.2.1 Patch available GHSA-9mqp-7v2h-2382
  • tensorflow-gpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-9mqp-7v2h-2382

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:-:*:*:*before 1.15.4; 2.0.0 to before 2.0.3; 2.1.0 to before 2.1.2; 2.2.0 to before 2.2.1; 2.3.0 to before 2.3.1VulnerableGoogle
cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:*15.2VulnerableopenSUSE
  • cpe:2.3:a:google:tensorflow:*:*:*:*:-:*:*:* Versions before 1.15.4; 2.0.0 to before 2.0.3; 2.1.0 to before 2.1.2; 2.2.0 to before 2.2.1; 2.3.0 to before 2.3.1 Vulnerable ·Google
  • cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Vulnerable ·openSUSE

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow (PyPI) Fixed in 1.15.4 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow (PyPI) Fixed in 2.0.3 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow (PyPI) Fixed in 2.1.2 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow (PyPI) Fixed in 2.2.1 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow (PyPI) Fixed in 2.3.1 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow-cpu (PyPI) Fixed in 1.15.4 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow-cpu (PyPI) Fixed in 2.0.3 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow-cpu (PyPI) Fixed in 2.1.2 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow-cpu (PyPI) Fixed in 2.2.1 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow-cpu (PyPI) Fixed in 2.3.1 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow-gpu (PyPI) Fixed in 1.15.4 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow-gpu (PyPI) Fixed in 2.0.3 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow-gpu (PyPI) Fixed in 2.1.2 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow-gpu (PyPI) Fixed in 2.2.1 Advisory →
  • Fix · GHSA-9mqp-7v2h-2382 tensorflow-gpu (PyPI) Fixed in 2.3.1 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    tensorflow — openSUSE-SU-2020:1766

    16 records Highest priority Priority MEDIUM 6 MEDIUM, 10 LOW

    Other records, highest priority first

    • TI-2020-11980 Data corruption in tensorflow-litePriority MEDIUM 44
    • TI-2020-11977 Data leak in TensorflowPriority MEDIUM 44
    • TI-2020-11979 Segfault and data corruption in tensorflow-litePriority MEDIUM 41

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-15194
  2. 2026-10-03 Alias added: GHSA-9mqp-7v2h-2382

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources