Read the docs
TI-2020-11969 Aliases CVE-2020-15197GHSA-qc53-44cj-vfvx

Denial of Service in Tensorflow

Priority LOW 29CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-617.

Summary

In Tensorflow before version 2.3.1, the `SparseCountSparseOutput` implementation does not validate that the input arguments form a valid sparse tensor. In particular, there is no validation that the `indices` tensor has rank 2. This tensor must be a matrix because code assumes its elements are accessed as elements of a matrix. However, malicious users can pass in tensors of different rank, resulting in a `CHECK` assertion failure and a crash. This can be used to cause denial of service in serving installations, if users are allowed to control the components of the input sparse tensor. The issue is patched in commit 3cbb917b4714766030b28eba9fb41bb97ce9ee02 and is released in TensorFlow version 2.3.1.

Why it matters now

EPSS 0.00726 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (PyPI): 2.3.1tensorflow-cpu (PyPI): 2.3.1+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow= 2.3.0—No fix listedCNA
—tensorflow (PyPI)2.3.0 to before 2.3.12.3.1Patch availableGHSA-qc53-44cj-vfvx
—tensorflow-cpu (PyPI)2.3.0 to before 2.3.12.3.1Patch availableGHSA-qc53-44cj-vfvx
—tensorflow-gpu (PyPI)2.3.0 to before 2.3.12.3.1Patch availableGHSA-qc53-44cj-vfvx
  • tensorflow VendorGoogle Affected = 2.3.0 Fixed in — No fix listed CNA
  • tensorflow (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-qc53-44cj-vfvx
  • tensorflow-cpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-qc53-44cj-vfvx
  • tensorflow-gpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-qc53-44cj-vfvx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:2.3.0:*:*:*:-:*:*:*2.3.0VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:2.3.0:*:*:*:-:*:*:* Versions 2.3.0 Vulnerable ·Google

Remediation

  • Fix · GHSA-qc53-44cj-vfvx tensorflow (PyPI) Fixed in 2.3.1 Advisory →
  • Fix · GHSA-qc53-44cj-vfvx tensorflow-cpu (PyPI) Fixed in 2.3.1 Advisory →
  • Fix · GHSA-qc53-44cj-vfvx tensorflow-gpu (PyPI) Fixed in 2.3.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-15197
  2. 2026-10-03 Alias added: GHSA-qc53-44cj-vfvx

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources