Denial of Service in Tensorflow
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
In Tensorflow before version 2.3.1, the `RaggedCountSparseOutput` does not validate that the input arguments form a valid ragged tensor. In particular, there is no validation that the `splits` tensor has the minimum required number of elements. Code uses this quantity to initialize a different data structure. Since `BatchedMap` is equivalent to a vector, it needs to have at least one element to not be `nullptr`. If user passes a `splits` tensor that is empty or has exactly one element, we get a `SIGABRT` signal raised by the operating system. The issue is patched in commit 3cbb917b4714766030b28eba9fb41bb97ce9ee02 and is released in TensorFlow version 2.3.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | = 2.3.0 | — | No fix listed | CNA | |
| — | tensorflow (PyPI) | 2.3.0 to before 2.3.1 | 2.3.1 | Patch available | GHSA-x5cp-9pcf-pp3h |
| — | tensorflow-cpu (PyPI) | 2.3.0 to before 2.3.1 | 2.3.1 | Patch available | GHSA-x5cp-9pcf-pp3h |
| — | tensorflow-gpu (PyPI) | 2.3.0 to before 2.3.1 | 2.3.1 | Patch available | GHSA-x5cp-9pcf-pp3h |
- tensorflow VendorGoogle Affected = 2.3.0 Fixed in — No fix listed CNA
- tensorflow (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-x5cp-9pcf-pp3h
- tensorflow-cpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-x5cp-9pcf-pp3h
- tensorflow-gpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-x5cp-9pcf-pp3h
Remediation
- Fix · GHSA-x5cp-9pcf-pp3h tensorflow (PyPI) Fixed in 2.3.1 Advisory →
- Fix · GHSA-x5cp-9pcf-pp3h tensorflow-cpu (PyPI) Fixed in 2.3.1 Advisory →
- Fix · GHSA-x5cp-9pcf-pp3h tensorflow-gpu (PyPI) Fixed in 2.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15199
- 2026-10-03 Alias added: GHSA-x5cp-9pcf-pp3h
References
Advisory 2
Other 4
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2020-279.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2020-314.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2020-122.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2020-15199 · CVE Program
- CVE-2020-15199 · NVD
- FIRST EPSS
- GHSA-x5cp-9pcf-pp3h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences