Read the docs
TI-2020-11974 Aliases CVE-2020-15202GHSA-h6fg-mjxg-hqq4

Integer truncation in Shard API usage

Priority MEDIUM 41CWE-197Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, the `Shard` API in TensorFlow expects the last argument to be a function taking two `int64` (i.e., `long long`) arguments. However, there are several places in TensorFlow where a lambda taking `int` or `int32` arguments is being used. In these cases, if the amount of work to be parallelized is large enough, integer truncation occurs. Depending on how the two arguments of the lambda are used, this can result in segfaults, read/write outside of heap allocated arrays, stack overflows, or data corruption. The issue is patched in commits 27b417360cbd671ef55915e4bb6bb06af8b8a832 and ca8c013b5e97b1373b3bb1c97ea655e69f31a575, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

Why it matters now

EPSS 0.01287 70th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (tensorflow): 1.15.4, 2.0.3, 2.1.2 +2tensorflow (PyPI): 1.15.4, 2.0.3, 2.1.2 +2+2 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflowbefore 1.15.4; 2.0.0 to before 2.0.3; 2.1.0 to before 2.1.2; 2.2.0 to before 2.2.1; 2.3.0 to before 2.3.11.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1Patch availableCNA
—tensorflow (PyPI)before 1.15.41.15.4Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow (PyPI)2.0.0 to before 2.0.32.0.3Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow (PyPI)2.1.0 to before 2.1.22.1.2Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow (PyPI)2.2.0 to before 2.2.12.2.1Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow (PyPI)2.3.0 to before 2.3.12.3.1Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow-cpu (PyPI)before 1.15.41.15.4Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow-cpu (PyPI)2.0.0 to before 2.0.32.0.3Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow-cpu (PyPI)2.1.0 to before 2.1.22.1.2Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow-cpu (PyPI)2.2.0 to before 2.2.12.2.1Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow-cpu (PyPI)2.3.0 to before 2.3.12.3.1Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow-gpu (PyPI)before 1.15.41.15.4Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow-gpu (PyPI)2.0.0 to before 2.0.32.0.3Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow-gpu (PyPI)2.1.0 to before 2.1.22.1.2Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow-gpu (PyPI)2.2.0 to before 2.2.12.2.1Patch availableGHSA-h6fg-mjxg-hqq4
—tensorflow-gpu (PyPI)2.3.0 to before 2.3.12.3.1Patch availableGHSA-h6fg-mjxg-hqq4
  • tensorflow VendorGoogle Affected before 1.15.4; 2.0.0 to before 2.0.3; 2.1.0 to before 2.1.2; 2.2.0 to before 2.2.1; 2.3.0 to before 2.3.1 Fixed in 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 1.15.4 Fixed in 1.15.4 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow (PyPI) Vendor— Affected 2.0.0 to before 2.0.3 Fixed in 2.0.3 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow (PyPI) Vendor— Affected 2.1.0 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow (PyPI) Vendor— Affected 2.2.0 to before 2.2.1 Fixed in 2.2.1 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow-cpu (PyPI) Vendor— Affected before 1.15.4 Fixed in 1.15.4 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow-cpu (PyPI) Vendor— Affected 2.0.0 to before 2.0.3 Fixed in 2.0.3 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow-cpu (PyPI) Vendor— Affected 2.1.0 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow-cpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.1 Fixed in 2.2.1 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow-cpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow-gpu (PyPI) Vendor— Affected before 1.15.4 Fixed in 1.15.4 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow-gpu (PyPI) Vendor— Affected 2.0.0 to before 2.0.3 Fixed in 2.0.3 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow-gpu (PyPI) Vendor— Affected 2.1.0 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow-gpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.1 Fixed in 2.2.1 Patch available GHSA-h6fg-mjxg-hqq4
  • tensorflow-gpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-h6fg-mjxg-hqq4

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:-:*:*:*before 1.15.4; 2.0.0 to before 2.0.3; 2.1.0 to before 2.1.2; 2.2.0 to before 2.2.1; 2.3.0 to before 2.3.1VulnerableGoogle
cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:*15.2VulnerableopenSUSE
  • cpe:2.3:a:google:tensorflow:*:*:*:*:-:*:*:* Versions before 1.15.4; 2.0.0 to before 2.0.3; 2.1.0 to before 2.1.2; 2.2.0 to before 2.2.1; 2.3.0 to before 2.3.1 Vulnerable ·Google
  • cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Vulnerable ·openSUSE

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow (PyPI) Fixed in 1.15.4 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow (PyPI) Fixed in 2.0.3 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow (PyPI) Fixed in 2.1.2 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow (PyPI) Fixed in 2.2.1 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow (PyPI) Fixed in 2.3.1 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow-cpu (PyPI) Fixed in 1.15.4 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow-cpu (PyPI) Fixed in 2.0.3 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow-cpu (PyPI) Fixed in 2.1.2 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow-cpu (PyPI) Fixed in 2.2.1 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow-cpu (PyPI) Fixed in 2.3.1 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow-gpu (PyPI) Fixed in 1.15.4 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow-gpu (PyPI) Fixed in 2.0.3 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow-gpu (PyPI) Fixed in 2.1.2 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow-gpu (PyPI) Fixed in 2.2.1 Advisory →
  • Fix · GHSA-h6fg-mjxg-hqq4 tensorflow-gpu (PyPI) Fixed in 2.3.1 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    tensorflow — openSUSE-SU-2020:1766

    16 records Highest priority Priority MEDIUM 6 MEDIUM, 10 LOW

    Other records, highest priority first

    • TI-2020-11980 Data corruption in tensorflow-litePriority MEDIUM 44
    • TI-2020-11977 Data leak in TensorflowPriority MEDIUM 44
    • TI-2020-11979 Segfault and data corruption in tensorflow-litePriority MEDIUM 41

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-15202
  2. 2026-10-03 Alias added: GHSA-h6fg-mjxg-hqq4

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources