Read the docs
TI-2020-11986 Aliases CVE-2020-15214GHSA-p2cq-cprg-frvm

Out of bounds write in tensorflow-lite

Priority LOW 36CWE-787Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
Low · Low · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

In TensorFlow Lite before versions 2.2.1 and 2.3.1, models using segment sum can trigger a write out bounds / segmentation fault if the segment ids are not sorted. Code assumes that the segment ids are in increasing order, using the last element of the tensor holding them to determine the dimensionality of output tensor. This results in allocating insufficient memory for the output tensor and in a write outside the bounds of the output array. This usually results in a segmentation fault, but depending on runtime conditions it can provide for a write gadget to be used in future memory corruption-based exploits. The issue is patched in commit 204945b19e44b57906c9344c0d00120eeeae178a and is released in TensorFlow versions 2.2.1, or 2.3.1. A potential workaround would be to add a custom `Verifier` to the model loading code to ensure that the segment ids are sorted, although this only handles the case when the segment ids are stored statically in the model. A similar validation could be done if the segment ids are generated at runtime between inference steps. If the segment ids are generated as outputs of a tensor during inference steps, then there are no possible workaround and users are advised to upgrade to patched code.

Why it matters now

EPSS 0.00671 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (tensorflow): 2.2.1, 2.3.1tensorflow (PyPI): 2.2.1, 2.3.1+2 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow2.2.0 to before 2.2.1; 2.3.0 to before 2.3.12.2.1, 2.3.1Patch availableCNA
—tensorflow (PyPI)2.2.0 to before 2.2.12.2.1Patch availableGHSA-p2cq-cprg-frvm
—tensorflow (PyPI)2.3.0 to before 2.3.12.3.1Patch availableGHSA-p2cq-cprg-frvm
—tensorflow-cpu (PyPI)2.2.0 to before 2.2.12.2.1Patch availableGHSA-p2cq-cprg-frvm
—tensorflow-cpu (PyPI)2.3.0 to before 2.3.12.3.1Patch availableGHSA-p2cq-cprg-frvm
—tensorflow-gpu (PyPI)2.2.0 to before 2.2.12.2.1Patch availableGHSA-p2cq-cprg-frvm
—tensorflow-gpu (PyPI)2.3.0 to before 2.3.12.3.1Patch availableGHSA-p2cq-cprg-frvm
  • tensorflow VendorGoogle Affected 2.2.0 to before 2.2.1; 2.3.0 to before 2.3.1 Fixed in 2.2.1, 2.3.1 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected 2.2.0 to before 2.2.1 Fixed in 2.2.1 Patch available GHSA-p2cq-cprg-frvm
  • tensorflow (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-p2cq-cprg-frvm
  • tensorflow-cpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.1 Fixed in 2.2.1 Patch available GHSA-p2cq-cprg-frvm
  • tensorflow-cpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-p2cq-cprg-frvm
  • tensorflow-gpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.1 Fixed in 2.2.1 Patch available GHSA-p2cq-cprg-frvm
  • tensorflow-gpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-p2cq-cprg-frvm

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:lite:*:*:*2.2.0 to before 2.2.1; 2.3.0 to before 2.3.1VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:lite:*:*:* Versions 2.2.0 to before 2.2.1; 2.3.0 to before 2.3.1 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.2.1, 2.3.1
  • Fix · GHSA-p2cq-cprg-frvm tensorflow (PyPI) Fixed in 2.2.1 Advisory →
  • Fix · GHSA-p2cq-cprg-frvm tensorflow (PyPI) Fixed in 2.3.1 Advisory →
  • Fix · GHSA-p2cq-cprg-frvm tensorflow-cpu (PyPI) Fixed in 2.2.1 Advisory →
  • Fix · GHSA-p2cq-cprg-frvm tensorflow-cpu (PyPI) Fixed in 2.3.1 Advisory →
  • Fix · GHSA-p2cq-cprg-frvm tensorflow-gpu (PyPI) Fixed in 2.2.1 Advisory →
  • Fix · GHSA-p2cq-cprg-frvm tensorflow-gpu (PyPI) Fixed in 2.3.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-15214
  2. 2026-10-03 Alias added: GHSA-p2cq-cprg-frvm

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources