Deserialization flaw in EOL Tapestry 4.
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
A Java Serialization vulnerability was found in Apache Tapestry 4. Apache Tapestry 4 will attempt to deserialize the "sp" parameter even before invoking the page's validate method, leading to deserialization without authentication. Apache Tapestry 4 reached end of life in 2008 and no update to address this issue will be released. Apache Tapestry 5 versions are not vulnerable to this issue. Users of Apache Tapestry 4 should upgrade to the latest Apache Tapestry 5 version.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Tapestry | Apache Tapestry 4 – 4 | — | No fix listed | CNA |
| — | org.apache.tapestry:tapestry-project (Maven) | 4.0 to before 5.0.1 | 5.0.1 | Patch available | GHSA-c566-2grg-mjwg |
- Apache Tapestry VendorApache Affected Apache Tapestry 4 – 4 Fixed in — No fix listed CNA
- org.apache.tapestry:tapestry-project (Maven) Vendor— Affected 4.0 to before 5.0.1 Fixed in 5.0.1 Patch available GHSA-c566-2grg-mjwg
Remediation
- Fix · GHSA-c566-2grg-mjwg org.apache.tapestry:tapestry-project (Maven) Fixed in 5.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-17531
- 2026-10-03 Alias added: GHSA-c566-2grg-mjwg
References
Advisory 4
- https://lists.apache.org/thread.html/r700a6aa234dbff0555d4187bdc8274d7e4c0afbf35b9a3457f09ee76%40%3Cusers.tapestry.apache.org%3E
- https://security.netapp.com/advisory/ntap-20210115-0007/
- [oss-security] 20221202 CVE-2022-46366: Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input
- https://nvd.nist.gov/vuln/detail/CVE-2020-17531
More Apache Tapestry vulnerabilities
- TI-2021-09208 Bypass of the fix for CVE-2019-0195 CVSS 3.1CRITICAL 9.8
- TI-2019-00172 Deserialization of untrusted data in Apache Tapestry CVSS 3.1CRITICAL 9.8
- TI-2019-07397 Observable discrepancy in Apache Tapestry CVSS 3.1CRITICAL 9.8
- TI-2022-22909 Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input CVSS 3.1CRITICAL 9.8
- TI-2014-01541 Apache Tapestry before 5.3.6 relies on client-side object storage without checking… CVSS 2.0HIGH 7.8
- TI-2021-11029 An Information Disclosure due to insufficient input validation exists in Apache Tapestry 5.4.0 and later CVSS 3.1HIGH 7.5
Sources
- CVE-2020-17531 · CVE Program
- CVE-2020-17531 · NVD
- FIRST EPSS
- GHSA-c566-2grg-mjwg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences