An Information Disclosure due to insufficient input validation exists in Apache Tapestry 5.4.0 and later
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure, Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200 and CWE-863.
Summary
Information Exposure vulnerability in context asset handling of Apache Tapestry allows an attacker to download files inside WEB-INF if using a specially-constructed URL. This was caused by an incomplete fix for CVE-2020-13953. This issue affects Apache Tapestry Apache Tapestry 5.4.0 version to Apache Tapestry 5.6.3; Apache Tapestry 5.7.0 version and Apache Tapestry 5.7.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Tapestry | Apache Tapestry to before Apache Tapestry 5.6.4; Apache Tapestry to before Apache Tapestry 5.7.2 | Apache Tapestry 5.6.4, Apache Tapestry 5.7.2 | Patch available | CNA |
| — | org.apache.tapestry:tapestry-core (Maven) | 5.4.0 to before 5.6.4 | 5.6.4 | Patch available | GHSA-ghm8-mmx7-xvg2 |
| — | org.apache.tapestry:tapestry-core (Maven) | 5.7.0 to before 5.7.2 | 5.7.2 | Patch available | GHSA-ghm8-mmx7-xvg2 |
- Apache Tapestry VendorApache Affected Apache Tapestry to before Apache Tapestry 5.6.4; Apache Tapestry to before Apache Tapestry 5.7.2 Fixed in Apache Tapestry 5.6.4, Apache Tapestry 5.7.2 Patch available CNA
- org.apache.tapestry:tapestry-core (Maven) Vendor— Affected 5.4.0 to before 5.6.4 Fixed in 5.6.4 Patch available GHSA-ghm8-mmx7-xvg2
- org.apache.tapestry:tapestry-core (Maven) Vendor— Affected 5.7.0 to before 5.7.2 Fixed in 5.7.2 Patch available GHSA-ghm8-mmx7-xvg2
Remediation
- Fix · CNA Apache Tapestry (Apache Software Foundation) Fixed in Apache Tapestry 5.6.4, Apache Tapestry 5.7.2
- Fix · GHSA-ghm8-mmx7-xvg2 org.apache.tapestry:tapestry-core (Maven) Fixed in 5.6.4 Advisory →
- Fix · GHSA-ghm8-mmx7-xvg2 org.apache.tapestry:tapestry-core (Maven) Fixed in 5.7.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-30638
- 2026-10-03 Alias added: GHSA-ghm8-mmx7-xvg2
References
Advisory 5
- https://lists.apache.org/thread.html/r37dab61fc7f7088d4311e7f995ef4117d58d86a675f0256caa6991eb%40%3Cusers.tapestry.apache.org%3E
- [oss-security] 20210427 CVE-2021-30638: An Information Disclosure due to insufficient input validation exists in Apache Tapestry 5.4.0 and later
- https://www.zerodayinitiative.com/advisories/ZDI-21-491/
- https://security.netapp.com/advisory/ntap-20210528-0004/
- https://nvd.nist.gov/vuln/detail/CVE-2021-30638
More Apache Tapestry vulnerabilities
- TI-2021-09208 Bypass of the fix for CVE-2019-0195 CVSS 3.1CRITICAL 9.8
- TI-2019-00172 Deserialization of untrusted data in Apache Tapestry CVSS 3.1CRITICAL 9.8
- TI-2020-13279 Deserialization flaw in EOL Tapestry 4. CVSS 3.1CRITICAL 9.8
- TI-2019-07397 Observable discrepancy in Apache Tapestry CVSS 3.1CRITICAL 9.8
- TI-2022-22909 Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input CVSS 3.1CRITICAL 9.8
- TI-2014-01541 Apache Tapestry before 5.3.6 relies on client-side object storage without checking… CVSS 2.0HIGH 7.8
Sources
- CVE-2021-30638 · CVE Program
- CVE-2021-30638 · NVD
- FIRST EPSS
- GHSA-ghm8-mmx7-xvg2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences