Read the docs
TI-2022-22909 Aliases CVE-2022-46366GHSA-vc39-x7w6-6vj7

Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input

Priority MEDIUM 49CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

Apache Tapestry 3.x allows deserialization of untrusted data, leading to remote code execution. This issue is similar to but distinct from CVE-2020-17531, which applies the the (also unsupported) 4.x version line. NOTE: This vulnerability only affects Apache Tapestry version line 3.x, which is no longer supported by the maintainer. Users are recommended to upgrade to a supported version line of Apache Tapestry.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.03668 89th percentileScored 2026-11-07
Fix Fixed Apache Tapestry (Apache Software Foundation): 4.0.0org.apache.tapestry:tapestry-core (Maven): 5.0.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache TapestryApache Tapestry to before 4.0.04.0.0Patch availableCNA
—org.apache.tapestry:tapestry-core (Maven)3.0 to before 5.0.15.0.1Patch availableGHSA-vc39-x7w6-6vj7
  • Apache Tapestry VendorApache Affected Apache Tapestry to before 4.0.0 Fixed in 4.0.0 Patch available CNA
  • org.apache.tapestry:tapestry-core (Maven) Vendor— Affected 3.0 to before 5.0.1 Fixed in 5.0.1 Patch available GHSA-vc39-x7w6-6vj7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:tapestry:*:*:*:*:*:*:*:*3.0.0 to before 4.0.0VulnerableApache
  • cpe:2.3:a:apache:tapestry:*:*:*:*:*:*:*:* Versions 3.0.0 to before 4.0.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Tapestry (Apache Software Foundation) Fixed in 4.0.0
  • Fix · GHSA-vc39-x7w6-6vj7 org.apache.tapestry:tapestry-core (Maven) Fixed in 5.0.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 9 products
  • Migration Toolkit for Applications 6
  • Migration Toolkit for Runtimes
  • Red Hat Decision Manager 7
  • Red Hat Fuse 7
  • Red Hat JBoss Data Grid 7
  • Red Hat JBoss Enterprise Application Platform 7
  • Red Hat JBoss Enterprise Application Platform Expansion Pack
  • Red Hat Process Automation 7
  • Red Hat Single Sign-On 7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-46366
  2. 2026-10-03 Alias added: GHSA-vc39-x7w6-6vj7

References

  • TI-2021-09208 Bypass of the fix for CVE-2019-0195 CVSS 3.1CRITICAL 9.8
  • TI-2019-00172 Deserialization of untrusted data in Apache Tapestry CVSS 3.1CRITICAL 9.8
  • TI-2020-13279 Deserialization flaw in EOL Tapestry 4. CVSS 3.1CRITICAL 9.8
  • TI-2019-07397 Observable discrepancy in Apache Tapestry CVSS 3.1CRITICAL 9.8
  • TI-2014-01541 Apache Tapestry before 5.3.6 relies on client-side object storage without checking… CVSS 2.0HIGH 7.8
  • TI-2021-11029 An Information Disclosure due to insufficient input validation exists in Apache Tapestry 5.4.0 and later CVSS 3.1HIGH 7.5
See all 10 →

Sources