Read the docs
TI-2020-13286 Aliases CVE-2020-17551GHSA-j29g-g982-pwpv

ImpressCMS 1.4.0 is affected by XSS in modules/system/admin.php which may result in arbitrary remote code execution.

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

ImpressCMS 1.4.0 is affected by XSS in modules/system/admin.php which may result in arbitrary remote code execution.

Why it matters now

EPSS 0.01134 66th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed impresscms/impresscms (Packagist): 1.4.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—impresscms/impresscms (Packagist)before 1.4.11.4.1Patch availableGHSA-j29g-g982-pwpv
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • impresscms/impresscms (Packagist) Vendor— Affected before 1.4.1 Fixed in 1.4.1 Patch available GHSA-j29g-g982-pwpv

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:impresscms:impresscms:1.4.0:*:*:*:*:*:*:*1.4.0VulnerableImpressCMS
  • cpe:2.3:a:impresscms:impresscms:1.4.0:*:*:*:*:*:*:* Versions 1.4.0 Vulnerable ·ImpressCMS

Remediation

  • Fix · GHSA-j29g-g982-pwpv impresscms/impresscms (Packagist) Fixed in 1.4.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-17551
  2. 2026-10-03 Alias added: GHSA-j29g-g982-pwpv

References

  • TI-2022-26365 ImpressCMS 1.4.4 - Unrestricted File Upload CVSS 4.0CRITICAL 9.3
  • TI-2019-15755 ImpressCMS 1.3.11 SQL Injection via bid Parameter CVSS 4.0HIGH 7.1
  • TI-2021-08319 ImpressCMS before 1.4.3 allows include/findusers.php groups SQL Injection. CVSS 3.1CRITICAL 9.8
  • TI-2023-19270 A cross-site scripting (XSS) vulnerability in ImpressCMS v1.4.5 and before allows… CVSS 3.1MEDIUM 4.8
  • TI-2022-08771 ImpressCMS before 1.4.2 allows unauthenticated remote code execution via .....///… CVSS 3.1CRITICAL 9.8
  • TI-2021-08320 ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant… CVSS 3.1CRITICAL 9.8
See all 20 →

Sources