Pega Platform through 8.4.x is affected by Cross Site Scripting (XSS) via the…
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Pega Platform through 8.4.x is affected by Cross Site Scripting (XSS) via the ConnectionID parameter, as demonstrated by a pyActivity=Data-TRACERSettings.pzStartTracerSession request to a PRAuth URI.
Why it matters now
EPSS 0.00686 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:* | 8.4 – 8.4.2 | Vulnerable | Pegasystems |
- cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:* Versions 8.4 – 8.4.2 Vulnerable ·Pegasystems
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2020-23957
- 2026-10-03 Alias added: GHSA-q835-q3qm-4v3c
References
More Pegasystems Pega Platform vulnerabilities
- TI-2023-15393 Pega platform clients who are using versions 6.1 through 7.3.1 may be utilizing default credentials CVSS 3.1CRITICAL 9.8
- TI-2020-12137 pyActivity in Pega Platform 8.4.0.237 has a security misconfiguration that leads to an… CVSS 3.1CRITICAL 9.8
- TI-2023-12673 Pega platform clients who are using versions 7.4 through 8.8.x and have upgraded from a… CVSS 3.1CRITICAL 9.8
- TI-2020-07035 Pega Platform before version 8.2.6 is affected by a Reflected Cross-Site Scripting… CVSS 3.1HIGH 8.8
- TI-2019-12322 PEGA Platform 8.3.0 is vulnerable to a direct… CVSS 3.1HIGH 8.1
- TI-2025-01892 Pega Platform versions 8.4.3 to Infinity 24.2.1 are affected by an XSS issue with Mashup CVSS 3.1HIGH 8.1
Sources
- CVE-2020-23957 · CVE Program
- CVE-2020-23957 · NVD
- FIRST EPSS
- GHSA-q835-q3qm-4v3c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences