Read the docs
TI-2020-15646 Aliases CVE-2020-25628GHSA-5x33-h32w-6vr2

Cross-site scripting in Moodle

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

The filter in the tag manager required extra sanitizing to prevent a reflected XSS risk. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

Why it matters now

EPSS 0.00984 62nd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.2, 3.8.5, 3.7.8 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Moodle3.9 to 3.9.1; 3.8 to 3.8.4; 3.7 to 3.7.7; 3.5 to 3.5.13; earlier unsupported versions—No fix listedCNA
—moodle/moodle (Packagist)3.9.0 to before 3.9.23.9.2Patch availableGHSA-5x33-h32w-6vr2
—moodle/moodle (Packagist)3.8.0 to before 3.8.53.8.5Patch availableGHSA-5x33-h32w-6vr2
—moodle/moodle (Packagist)3.7.0 to before 3.7.83.7.8Patch availableGHSA-5x33-h32w-6vr2
—moodle/moodle (Packagist)3.5 to before 3.5.143.5.14Patch availableGHSA-5x33-h32w-6vr2
  • Moodle Vendor— Affected 3.9 to 3.9.1; 3.8 to 3.8.4; 3.7 to 3.7.7; 3.5 to 3.5.13; earlier unsupported versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.9.0 to before 3.9.2 Fixed in 3.9.2 Patch available GHSA-5x33-h32w-6vr2
  • moodle/moodle (Packagist) Vendor— Affected 3.8.0 to before 3.8.5 Fixed in 3.8.5 Patch available GHSA-5x33-h32w-6vr2
  • moodle/moodle (Packagist) Vendor— Affected 3.7.0 to before 3.7.8 Fixed in 3.7.8 Patch available GHSA-5x33-h32w-6vr2
  • moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.14 Fixed in 3.5.14 Patch available GHSA-5x33-h32w-6vr2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.5.0 to before 3.5.14; 3.7.0 to before 3.7.8; 3.8.0 to before 3.8.5; 3.9.0 to before 3.9.2VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.5.0 to before 3.5.14; 3.7.0 to before 3.7.8; 3.8.0 to before 3.8.5; 3.9.0 to before 3.9.2 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-5x33-h32w-6vr2 moodle/moodle (Packagist) Fixed in 3.9.2 Advisory →
  • Fix · GHSA-5x33-h32w-6vr2 moodle/moodle (Packagist) Fixed in 3.8.5 Advisory →
  • Fix · GHSA-5x33-h32w-6vr2 moodle/moodle (Packagist) Fixed in 3.7.8 Advisory →
  • Fix · GHSA-5x33-h32w-6vr2 moodle/moodle (Packagist) Fixed in 3.5.14 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-25628
  2. 2026-10-03 Alias added: GHSA-5x33-h32w-6vr2

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources