Improper access control in Moodle
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Moodle | 3.9 to 3.9.1; 3.8 to 3.8.4; 3.7 to 3.7.7; 3.5 to 3.5.13; earlier unsupported versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.9 to before 3.9.2 | 3.9.2 | Patch available | GHSA-f5r8-7h4f-jr9x |
| — | moodle/moodle (Packagist) | 3.8 to before 3.8.5 | 3.8.5 | Patch available | GHSA-f5r8-7h4f-jr9x |
| — | moodle/moodle (Packagist) | 3.7 to before 3.7.8 | 3.7.8 | Patch available | GHSA-f5r8-7h4f-jr9x |
| — | moodle/moodle (Packagist) | 3.5 to before 3.5.14 | 3.5.14 | Patch available | GHSA-f5r8-7h4f-jr9x |
- Moodle Vendor— Affected 3.9 to 3.9.1; 3.8 to 3.8.4; 3.7 to 3.7.7; 3.5 to 3.5.13; earlier unsupported versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.2 Fixed in 3.9.2 Patch available GHSA-f5r8-7h4f-jr9x
- moodle/moodle (Packagist) Vendor— Affected 3.8 to before 3.8.5 Fixed in 3.8.5 Patch available GHSA-f5r8-7h4f-jr9x
- moodle/moodle (Packagist) Vendor— Affected 3.7 to before 3.7.8 Fixed in 3.7.8 Patch available GHSA-f5r8-7h4f-jr9x
- moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.14 Fixed in 3.5.14 Patch available GHSA-f5r8-7h4f-jr9x
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.5.0 to before 3.5.14; 3.7.0 to before 3.7.8; 3.8.0 to before 3.8.5; 3.9.0 to before 3.9.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.5.0 to before 3.5.14; 3.7.0 to before 3.7.8; 3.8.0 to before 3.8.5; 3.9.0 to before 3.9.2 Vulnerable ·Moodle
Remediation
- Fix · GHSA-f5r8-7h4f-jr9x moodle/moodle (Packagist) Fixed in 3.9.2 Advisory →
- Fix · GHSA-f5r8-7h4f-jr9x moodle/moodle (Packagist) Fixed in 3.8.5 Advisory →
- Fix · GHSA-f5r8-7h4f-jr9x moodle/moodle (Packagist) Fixed in 3.7.8 Advisory →
- Fix · GHSA-f5r8-7h4f-jr9x moodle/moodle (Packagist) Fixed in 3.5.14 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-25629
- 2026-10-03 Alias added: GHSA-f5r8-7h4f-jr9x
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2020-25629 · CVE Program
- CVE-2020-25629 · NVD
- FIRST EPSS
- GHSA-f5r8-7h4f-jr9x · GitHub Advisory Database · CC BY 4.0
- CVE-2020-25629 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences