Cross-site scripting in Moodle
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability was found in Moodle 3.9 to 3.9.1, 3.8 to 3.8.4 and 3.7 to 3.7.7 where it was possible to include JavaScript in a book's chapter title, which was not escaped on the "Add new chapter" page. This is fixed in 3.9.2, 3.8.5 and 3.7.8.
Why it matters now
EPSS 0.00934 60th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.2, 3.8.5, 3.7.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Moodle | 3.9 to 3.9.1, 3.8 to 3.8.4 and 3.7 to 3.7.7 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.9 to before 3.9.2 | 3.9.2 | Patch available | GHSA-4w4j-9533-82qg |
| — | moodle/moodle (Packagist) | 3.8 to before 3.8.5 | 3.8.5 | Patch available | GHSA-4w4j-9533-82qg |
| — | moodle/moodle (Packagist) | 3.7 to before 3.7.8 | 3.7.8 | Patch available | GHSA-4w4j-9533-82qg |
- Moodle Vendor— Affected 3.9 to 3.9.1, 3.8 to 3.8.4 and 3.7 to 3.7.7 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.2 Fixed in 3.9.2 Patch available GHSA-4w4j-9533-82qg
- moodle/moodle (Packagist) Vendor— Affected 3.8 to before 3.8.5 Fixed in 3.8.5 Patch available GHSA-4w4j-9533-82qg
- moodle/moodle (Packagist) Vendor— Affected 3.7 to before 3.7.8 Fixed in 3.7.8 Patch available GHSA-4w4j-9533-82qg
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.7.0 to before 3.7.8; 3.8.0 to before 3.8.5; 3.9.0 to before 3.9.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.7.0 to before 3.7.8; 3.8.0 to before 3.8.5; 3.9.0 to before 3.9.2 Vulnerable ·Moodle
Remediation
- Fix · GHSA-4w4j-9533-82qg moodle/moodle (Packagist) Fixed in 3.9.2 Advisory →
- Fix · GHSA-4w4j-9533-82qg moodle/moodle (Packagist) Fixed in 3.8.5 Advisory →
- Fix · GHSA-4w4j-9533-82qg moodle/moodle (Packagist) Fixed in 3.7.8 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-25631
- 2026-10-03 Alias added: GHSA-4w4j-9533-82qg
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2020-25631 · CVE Program
- CVE-2020-25631 · NVD
- FIRST EPSS
- GHSA-4w4j-9533-82qg · GitHub Advisory Database · CC BY 4.0
- CVE-2020-25631 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences