Read the docs
TI-2020-15715 Aliases CVE-2020-25699GHSA-h77r-rp97-7rv4

Incorrect authorization in moodle

Priority LOW 36CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass, Privilege escalation
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863 and CWE-269.

Summary

In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles within that course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

Why it matters now

EPSS 0.01607 76th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.3, 3.8.6, 3.7.9 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodleFixed in 3.9.3; Fixed in 3.8.6; Fixed in 3.7.9; Fixed in 3.5.15; Fixed in 3.10—No fix listedCNA
—moodle/moodle (Packagist)3.9.0 to before 3.9.33.9.3Patch availableGHSA-h77r-rp97-7rv4
—moodle/moodle (Packagist)3.8.0 to before 3.8.63.8.6Patch availableGHSA-h77r-rp97-7rv4
—moodle/moodle (Packagist)3.7.0 to before 3.7.93.7.9Patch availableGHSA-h77r-rp97-7rv4
—moodle/moodle (Packagist)3.5 to before 3.5.153.5.15Patch availableGHSA-h77r-rp97-7rv4
  • moodle Vendor— Affected Fixed in 3.9.3; Fixed in 3.8.6; Fixed in 3.7.9; Fixed in 3.5.15; Fixed in 3.10 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.9.0 to before 3.9.3 Fixed in 3.9.3 Patch available GHSA-h77r-rp97-7rv4
  • moodle/moodle (Packagist) Vendor— Affected 3.8.0 to before 3.8.6 Fixed in 3.8.6 Patch available GHSA-h77r-rp97-7rv4
  • moodle/moodle (Packagist) Vendor— Affected 3.7.0 to before 3.7.9 Fixed in 3.7.9 Patch available GHSA-h77r-rp97-7rv4
  • moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.15 Fixed in 3.5.15 Patch available GHSA-h77r-rp97-7rv4

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.5.0 – 3.5.14; 3.7.0 – 3.7.8; 3.8.0 – 3.8.5; 3.9.0 – 3.9.2VulnerableMoodle
cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*32VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:*33VulnerableFedoraproject
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.5.0 – 3.5.14; 3.7.0 – 3.7.8; 3.8.0 – 3.8.5; 3.9.0 – 3.9.2 Vulnerable ·Moodle
  • cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject

Remediation

  • Fix · GHSA-h77r-rp97-7rv4 moodle/moodle (Packagist) Fixed in 3.9.3 Advisory →
  • Fix · GHSA-h77r-rp97-7rv4 moodle/moodle (Packagist) Fixed in 3.8.6 Advisory →
  • Fix · GHSA-h77r-rp97-7rv4 moodle/moodle (Packagist) Fixed in 3.7.9 Advisory →
  • Fix · GHSA-h77r-rp97-7rv4 moodle/moodle (Packagist) Fixed in 3.5.15 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-25699
  2. 2026-10-03 Alias added: GHSA-h77r-rp97-7rv4

References

Sources