Cross-site scripting in moodle
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Moodle, it was possible to include JavaScript when re-naming content bank items. Versions affected: 3.9 to 3.9.2. This is fixed in moodle 3.9.3 and 3.10.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | Fixed in 3.9.3, Fixed in 3.10 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.9.0 to before 3.9.3 | 3.9.3 | Patch available | GHSA-pgcp-m69h-p2gr |
- moodle Vendor— Affected Fixed in 3.9.3, Fixed in 3.10 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.9.0 to before 3.9.3 Fixed in 3.9.3 Patch available GHSA-pgcp-m69h-p2gr
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.9 to before 3.9.3 | Vulnerable | Moodle |
| cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* | 32 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9 to before 3.9.3 Vulnerable ·Moodle
- cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-pgcp-m69h-p2gr moodle/moodle (Packagist) Fixed in 3.9.3 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
moodle — FEDORA-2020-db73e37548
6 records Highest priority Priority LOW 6 LOW
Other records, highest priority first
- TI-2020-15714 Improper access control in moodlePriority LOW 37
- TI-2020-15715 Incorrect authorization in moodlePriority LOW 36
- TI-2020-15716 SQL injection in moodlePriority LOW 32
- Advisory ·
moodle — FEDORA-2020-304aa2c365
6 records Highest priority Priority LOW 6 LOW
Other records, highest priority first
- TI-2020-15714 Improper access control in moodlePriority LOW 37
- TI-2020-15715 Incorrect authorization in moodlePriority LOW 36
- TI-2020-15716 SQL injection in moodlePriority LOW 32
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-25702
- 2026-10-03 Alias added: GHSA-pgcp-m69h-p2gr
References
Advisory 5
Sources
- CVE-2020-25702 · CVE Program
- CVE-2020-25702 · NVD
- FIRST EPSS
- GHSA-pgcp-m69h-p2gr · GitHub Advisory Database · CC BY 4.0
- CVE-2020-25702 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences