Cross-site scripting in Dell Integrated Dell Remote Access Controller
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Dell EMC iDRAC9 versions prior to 4.32.10.00 and 4.40.00.00 contain a reflected cross-site scripting vulnerability in the iDRAC9 web application. A remote attacker could potentially exploit this vulnerability to run malicious HTML or JavaScript in a victim’s browser by tricking a victim in to following a specially crafted link.
Why it matters now
EPSS 0.01003 63rd percentileScored 2026-11-07
Fix Fixed Integrated Dell Remote Access Controller (iDRAC) (Dell): 4.32.10.00 and 4.40.00.00
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | Integrated Dell Remote Access Controller (iDRAC) | before 4.32.10.00 and 4.40.00.00 | 4.32.10.00 and 4.40.00.00 | Patch available | CNA |
- Integrated Dell Remote Access Controller (iDRAC) VendorDell Affected before 4.32.10.00 and 4.40.00.00 Fixed in 4.32.10.00 and 4.40.00.00 Patch available CNA
Remediation
- Fix · CNA Integrated Dell Remote Access Controller (iDRAC) (Dell) Fixed in 4.32.10.00 and 4.40.00.00
Timeline
- 2026-10-02 Threatist record created from CVE-2020-26198
- 2026-10-03 Alias added: GHSA-4mxg-rfj6-76c7
References
More Dell Idrac9 Firmware vulnerabilities
- TI-2020-04396 Stack-based buffer overflow in Dell Integrated Dell Remote Access Controller CVSS 3.1CRITICAL 9.8
- TI-2019-02726 Buffer overflow in Dell EMC iDRAC CVSS 3.1CRITICAL 9.8
- TI-2019-02728 WS-MAN Authentication Bypass Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2019-02727 Web Interface Authentication Bypass Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2021-04623 Improper authentication in Dell Integrated Dell Remote Access Controller CVSS 3.1CRITICAL 10.0
- TI-2018-01149 iDRAC7/iDRAC8/iDrac9 contains a command injection vulnerability in the SNMP agent. CVSS 3.0HIGH 8.8
Sources
- CVE-2020-26198 · CVE Program
- CVE-2020-26198 · NVD
- FIRST EPSS
- GHSA-4mxg-rfj6-76c7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences