Uninitialized memory access in Eigen types in TensorFlow
Priority LOW 24CWE-908Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
In affected versions of TensorFlow under certain cases a saved model can trigger use of uninitialized values during code execution. This is caused by having tensor buffers be filled with the default value of the type but forgetting to default initialize the quantized floating point types in Eigen. This is fixed in versions 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2, and 2.4.0.
Why it matters now
EPSS 0.00261 18th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (tensorflow): 1.15.5, 2.0.4, 2.1.3 +2tensorflow (PyPI): 1.15.5, 2.0.4, 2.1.3 +2+2 more products
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | before 1.15.5; 2.0.0 to before 2.0.4; 2.1.0 to before 2.1.3; 2.2.0 to before 2.2.2; 2.3.0 to before 2.3.2 | 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 | Patch available | CNA | |
| — | tensorflow (PyPI) | before 1.15.5 | 1.15.5 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow (PyPI) | 2.0.0 to before 2.0.4 | 2.0.4 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow (PyPI) | 2.1.0 to before 2.1.3 | 2.1.3 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow (PyPI) | 2.2.0 to before 2.2.2 | 2.2.2 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow (PyPI) | 2.3.0 to before 2.3.2 | 2.3.2 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow-cpu (PyPI) | before 1.15.5 | 1.15.5 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow-cpu (PyPI) | 2.0.0 to before 2.0.4 | 2.0.4 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow-cpu (PyPI) | 2.1.0 to before 2.1.3 | 2.1.3 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow-cpu (PyPI) | 2.2.0 to before 2.2.2 | 2.2.2 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow-cpu (PyPI) | 2.3.0 to before 2.3.2 | 2.3.2 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow-gpu (PyPI) | before 1.15.5 | 1.15.5 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow-gpu (PyPI) | 2.0.0 to before 2.0.4 | 2.0.4 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow-gpu (PyPI) | 2.1.0 to before 2.1.3 | 2.1.3 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow-gpu (PyPI) | 2.2.0 to before 2.2.2 | 2.2.2 | Patch available | GHSA-qhxx-j73r-qpm2 |
| — | tensorflow-gpu (PyPI) | 2.3.0 to before 2.3.2 | 2.3.2 | Patch available | GHSA-qhxx-j73r-qpm2 |
- tensorflow VendorGoogle Affected before 1.15.5; 2.0.0 to before 2.0.4; 2.1.0 to before 2.1.3; 2.2.0 to before 2.2.2; 2.3.0 to before 2.3.2 Fixed in 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 Patch available CNA
- tensorflow (PyPI) Vendor— Affected before 1.15.5 Fixed in 1.15.5 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow (PyPI) Vendor— Affected 2.0.0 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow (PyPI) Vendor— Affected 2.1.0 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow (PyPI) Vendor— Affected 2.2.0 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow (PyPI) Vendor— Affected 2.3.0 to before 2.3.2 Fixed in 2.3.2 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow-cpu (PyPI) Vendor— Affected before 1.15.5 Fixed in 1.15.5 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow-cpu (PyPI) Vendor— Affected 2.0.0 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow-cpu (PyPI) Vendor— Affected 2.1.0 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow-cpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow-cpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.2 Fixed in 2.3.2 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow-gpu (PyPI) Vendor— Affected before 1.15.5 Fixed in 1.15.5 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow-gpu (PyPI) Vendor— Affected 2.0.0 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow-gpu (PyPI) Vendor— Affected 2.1.0 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow-gpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-qhxx-j73r-qpm2
- tensorflow-gpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.2 Fixed in 2.3.2 Patch available GHSA-qhxx-j73r-qpm2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | before 1.15.5; 2.0.0 to before 2.0.4; 2.1.0 to before 2.1.3; 2.2.0 to before 2.2.2; 2.3.0 to before 2.3.2 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 1.15.5; 2.0.0 to before 2.0.4; 2.1.0 to before 2.1.3; 2.2.0 to before 2.2.2; 2.3.0 to before 2.3.2 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow (PyPI) Fixed in 1.15.5 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow (PyPI) Fixed in 2.0.4 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow (PyPI) Fixed in 2.1.3 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow (PyPI) Fixed in 2.2.2 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow (PyPI) Fixed in 2.3.2 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow-cpu (PyPI) Fixed in 1.15.5 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow-cpu (PyPI) Fixed in 2.0.4 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow-cpu (PyPI) Fixed in 2.1.3 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow-cpu (PyPI) Fixed in 2.2.2 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow-cpu (PyPI) Fixed in 2.3.2 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow-gpu (PyPI) Fixed in 1.15.5 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow-gpu (PyPI) Fixed in 2.0.4 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow-gpu (PyPI) Fixed in 2.1.3 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow-gpu (PyPI) Fixed in 2.2.2 Advisory →
- Fix · GHSA-qhxx-j73r-qpm2 tensorflow-gpu (PyPI) Fixed in 2.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-26266
- 2026-10-03 Alias added: GHSA-qhxx-j73r-qpm2
References
Other 4
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2020-297.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2020-332.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2020-254.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2020-26266 · CVE Program
- CVE-2020-26266 · NVD
- FIRST EPSS
- GHSA-qhxx-j73r-qpm2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences