Heap out of bounds access in MakeEdge in TensorFlow
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
In affected versions of TensorFlow under certain cases, loading a saved model can result in accessing uninitialized memory while building the computation graph. The MakeEdge function creates an edge between one output tensor of the src node (given by output_index) and the input slot of the dst node (given by input_index). This is only possible if the types of the tensors on both sides coincide, so the function begins by obtaining the corresponding DataType values and comparing these for equality. However, there is no check that the indices point to inside of the arrays they index into. Thus, this can result in accessing data out of bounds of the corresponding heap allocated arrays. In most scenarios, this can manifest as unitialized data access, but if the index points far away from the boundaries of the arrays this can be used to leak addresses from the library. This is fixed in versions 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2, and 2.4.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | before 1.15.5; 2.0.0 to before 2.0.4; 2.1.0 to before 2.1.3; 2.2.0 to before 2.2.2; 2.3.0 to before 2.3.2 | 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 | Patch available | CNA | |
| — | tensorflow (PyPI) | before 1.15.5 | 1.15.5 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow (PyPI) | 2.0.0 to before 2.0.4 | 2.0.4 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow (PyPI) | 2.1.0 to before 2.1.3 | 2.1.3 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow (PyPI) | 2.2.0 to before 2.2.2 | 2.2.2 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow (PyPI) | 2.3.0 to before 2.3.2 | 2.3.2 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow-cpu (PyPI) | before 1.15.5 | 1.15.5 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow-cpu (PyPI) | 2.0.0 to before 2.0.4 | 2.0.4 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow-cpu (PyPI) | 2.1.0 to before 2.1.3 | 2.1.3 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow-cpu (PyPI) | 2.2.0 to before 2.2.2 | 2.2.2 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow-cpu (PyPI) | 2.3.0 to before 2.3.2 | 2.3.2 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow-gpu (PyPI) | before 1.15.5 | 1.15.5 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow-gpu (PyPI) | 2.0.0 to before 2.0.4 | 2.0.4 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow-gpu (PyPI) | 2.1.0 to before 2.1.3 | 2.1.3 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow-gpu (PyPI) | 2.2.0 to before 2.2.2 | 2.2.2 | Patch available | GHSA-q263-fvxm-m5mw |
| — | tensorflow-gpu (PyPI) | 2.3.0 to before 2.3.2 | 2.3.2 | Patch available | GHSA-q263-fvxm-m5mw |
- tensorflow VendorGoogle Affected before 1.15.5; 2.0.0 to before 2.0.4; 2.1.0 to before 2.1.3; 2.2.0 to before 2.2.2; 2.3.0 to before 2.3.2 Fixed in 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2 Patch available CNA
- tensorflow (PyPI) Vendor— Affected before 1.15.5 Fixed in 1.15.5 Patch available GHSA-q263-fvxm-m5mw
- tensorflow (PyPI) Vendor— Affected 2.0.0 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-q263-fvxm-m5mw
- tensorflow (PyPI) Vendor— Affected 2.1.0 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-q263-fvxm-m5mw
- tensorflow (PyPI) Vendor— Affected 2.2.0 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-q263-fvxm-m5mw
- tensorflow (PyPI) Vendor— Affected 2.3.0 to before 2.3.2 Fixed in 2.3.2 Patch available GHSA-q263-fvxm-m5mw
- tensorflow-cpu (PyPI) Vendor— Affected before 1.15.5 Fixed in 1.15.5 Patch available GHSA-q263-fvxm-m5mw
- tensorflow-cpu (PyPI) Vendor— Affected 2.0.0 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-q263-fvxm-m5mw
- tensorflow-cpu (PyPI) Vendor— Affected 2.1.0 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-q263-fvxm-m5mw
- tensorflow-cpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-q263-fvxm-m5mw
- tensorflow-cpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.2 Fixed in 2.3.2 Patch available GHSA-q263-fvxm-m5mw
- tensorflow-gpu (PyPI) Vendor— Affected before 1.15.5 Fixed in 1.15.5 Patch available GHSA-q263-fvxm-m5mw
- tensorflow-gpu (PyPI) Vendor— Affected 2.0.0 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-q263-fvxm-m5mw
- tensorflow-gpu (PyPI) Vendor— Affected 2.1.0 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-q263-fvxm-m5mw
- tensorflow-gpu (PyPI) Vendor— Affected 2.2.0 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-q263-fvxm-m5mw
- tensorflow-gpu (PyPI) Vendor— Affected 2.3.0 to before 2.3.2 Fixed in 2.3.2 Patch available GHSA-q263-fvxm-m5mw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | before 1.15.5; 2.0.0 to before 2.0.4; 2.1.0 to before 2.1.3; 2.2.0 to before 2.2.2; 2.3.0 to before 2.3.2 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 1.15.5; 2.0.0 to before 2.0.4; 2.1.0 to before 2.1.3; 2.2.0 to before 2.2.2; 2.3.0 to before 2.3.2 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2
- Fix · GHSA-q263-fvxm-m5mw tensorflow (PyPI) Fixed in 1.15.5 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow (PyPI) Fixed in 2.0.4 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow (PyPI) Fixed in 2.1.3 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow (PyPI) Fixed in 2.2.2 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow (PyPI) Fixed in 2.3.2 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow-cpu (PyPI) Fixed in 1.15.5 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow-cpu (PyPI) Fixed in 2.0.4 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow-cpu (PyPI) Fixed in 2.1.3 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow-cpu (PyPI) Fixed in 2.2.2 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow-cpu (PyPI) Fixed in 2.3.2 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow-gpu (PyPI) Fixed in 1.15.5 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow-gpu (PyPI) Fixed in 2.0.4 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow-gpu (PyPI) Fixed in 2.1.3 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow-gpu (PyPI) Fixed in 2.2.2 Advisory →
- Fix · GHSA-q263-fvxm-m5mw tensorflow-gpu (PyPI) Fixed in 2.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-26271
- 2026-10-03 Alias added: GHSA-q263-fvxm-m5mw
References
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2020-26271 · CVE Program
- CVE-2020-26271 · NVD
- FIRST EPSS
- GHSA-q263-fvxm-m5mw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences