Read the docs
TI-2020-17840 Aliases CVE-2020-35128GHSA-98j2-3jv7-274m

Mautic before 3.2.4 is affected by stored XSS.

Priority MEDIUM 42CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Mautic before 3.2.4 is affected by stored XSS. An attacker with permission to manage companies, an application feature, could attack other users, including administrators. For example, by loading an externally crafted JavaScript file, an attacker could eventually perform actions as the target user. These actions include changing the user passwords, altering user or email addresses, or adding a new administrator to the system.

Why it matters now

EPSS 0.01674 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed mautic/core (Packagist): 3.2.4, 2.16.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mautic/core (Packagist)3.2.0 to before 3.2.43.2.4Patch availableGHSA-98j2-3jv7-274m
—mautic/core (Packagist)2.0.0 to before 2.16.52.16.5Patch availableGHSA-98j2-3jv7-274m
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mautic/core (Packagist) Vendor— Affected 3.2.0 to before 3.2.4 Fixed in 3.2.4 Patch available GHSA-98j2-3jv7-274m
  • mautic/core (Packagist) Vendor— Affected 2.0.0 to before 2.16.5 Fixed in 2.16.5 Patch available GHSA-98j2-3jv7-274m

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:acquia:mautic:*:*:*:*:*:*:*:*2.0.0 to before 2.16.5; 3.2.0 to before 3.2.4VulnerableAcquia
  • cpe:2.3:a:acquia:mautic:*:*:*:*:*:*:*:* Versions 2.0.0 to before 2.16.5; 3.2.0 to before 3.2.4 Vulnerable ·Acquia

Remediation

  • Fix · GHSA-98j2-3jv7-274m mautic/core (Packagist) Fixed in 3.2.4 Advisory →
  • Fix · GHSA-98j2-3jv7-274m mautic/core (Packagist) Fixed in 2.16.5 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-35128
  2. 2026-10-03 Alias added: GHSA-98j2-3jv7-274m

References

  • TI-2022-09344 Cross-site scripting in Mautic CVSS 3.1CRITICAL 9.6
  • TI-2024-31435 Remote Code Execution & File Deletion in Asset Uploads CVSS 3.1CRITICAL 9.9
  • TI-2020-17837 A cross-site scripting (XSS) vulnerability in the forms component of Mautic before 3.2.4… CVSS 3.1CRITICAL 9.6
  • TI-2020-17836 A cross-site scripting (XSS) vulnerability in the assets component of Mautic before 3.2.4… CVSS 3.1CRITICAL 9.6
  • TI-2022-09342 Improper regex in htaccess file CVSS 3.1CRITICAL 9.1
  • TI-2021-09250 XSS Cross-site Scripting Stored (XSS) - Description field CVSS 3.1CRITICAL 9.0
See all 34 →

Sources