XSS Cross-site Scripting Stored (XSS) - Description field
Priority MEDIUM 42CWE-80Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-80.
Summary
Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be exploited by a logged in user of Mautic with the appropriate permissions. This could lead to the user having elevated access to the system.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0062 49th percentileScored 2026-11-07
Fix Fixed mautic/core (Packagist): 4.4.12
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mautic | Mautic | >= 1.0.0-beta2 – <= 4.4.11 | — | No fix listed | CNA |
| — | mautic/core (Packagist) | 1.0.0-beta2 to before 4.4.12 | 4.4.12 | Patch available | GHSA-2rc5-2755-v422 |
- Mautic VendorMautic Affected >= 1.0.0-beta2 – <= 4.4.11 Fixed in — No fix listed CNA
- mautic/core (Packagist) Vendor— Affected 1.0.0-beta2 to before 4.4.12 Fixed in 4.4.12 Patch available GHSA-2rc5-2755-v422
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:acquia:mautic:*:*:*:*:*:*:*:* | 1.0.0 to before 4.4.12 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:-:*:*:*:*:*:* | 1.0.0 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:beta2:*:*:*:*:*:* | 1.0.0 beta2 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:beta3:*:*:*:*:*:* | 1.0.0 beta3 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:beta4:*:*:*:*:*:* | 1.0.0 beta4 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:rc1:*:*:*:*:*:* | 1.0.0 rc1 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:rc2:*:*:*:*:*:* | 1.0.0 rc2 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:rc3:*:*:*:*:*:* | 1.0.0 rc3 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:rc4:*:*:*:*:*:* | 1.0.0 rc4 | Vulnerable | Acquia |
- cpe:2.3:a:acquia:mautic:*:*:*:*:*:*:*:* Versions 1.0.0 to before 4.4.12 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:-:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:beta2:*:*:*:*:*:* Versions 1.0.0 beta2 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:beta3:*:*:*:*:*:* Versions 1.0.0 beta3 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:beta4:*:*:*:*:*:* Versions 1.0.0 beta4 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:rc1:*:*:*:*:*:* Versions 1.0.0 rc1 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:rc2:*:*:*:*:*:* Versions 1.0.0 rc2 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:rc3:*:*:*:*:*:* Versions 1.0.0 rc3 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:rc4:*:*:*:*:*:* Versions 1.0.0 rc4 Vulnerable ·Acquia
Remediation
- Fix · GHSA-2rc5-2755-v422 mautic/core (Packagist) Fixed in 4.4.12 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-27915
- 2026-10-03 Alias added: GHSA-2rc5-2755-v422
References
More Mautic vulnerabilities
- TI-2022-09344 Cross-site scripting in Mautic CVSS 3.1CRITICAL 9.6
- TI-2024-02543 Predictable Page Indexing Might Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.3
- TI-2024-02544 Improper Access Control Issues Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.4
- TI-2024-03218 Improper Access Control Leads to Server-Side Request Forgery in Mautic CVSS 3.1MEDIUM 5.0
- TI-2024-31435 Remote Code Execution & File Deletion in Asset Uploads CVSS 3.1CRITICAL 9.9
- TI-2018-05847 Mautic before 2.13.0 allows CSV injection. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2021-27915 · CVE Program
- CVE-2021-27915 · NVD
- FIRST EPSS
- GHSA-2rc5-2755-v422 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences