OpenMRS Admin UI Module Account Setup AccountPageController.java sendErrorMessage cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability classified as problematic has been found in OpenMRS Admin UI Module up to 1.4.x. Affected is the function sendErrorMessage of the file omod/src/main/java/org/openmrs/module/adminui/page/controller/systemadmin/accounts/AccountPageController.java of the component Account Setup Handler. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.5.0 is able to address this issue. The name of the patch is 702fbfdac7c4418f23bb5f6452482b4a88020061. It is recommended to upgrade the affected component. VDB-216918 is the identifier assigned to this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36636
- 2026-10-03 Alias added: GHSA-cwx3-2j2v-5qxw
References
More OpenMRS Admin Ui Module vulnerabilities
- TI-2021-03150 OpenMRS Admin UI Module Manage Privilege Page privilege.gsp cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2021-03149 OpenMRS Admin UI Module location.gsp cross site scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2020-36636 · CVE Program
- CVE-2020-36636 · NVD
- FIRST EPSS
- GHSA-cwx3-2j2v-5qxw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences